Microphone not working Windows 10

Highlighted
New Contributor

When I participate in a voice/video meeting in Teams my microphone in my headset isn't working, i tried using the test call but it doesn't pick up the microphone, I tried testing the microphone in skype and there I had the same problem while in discord the microphone works.

 

when I look in my settings the programs have acces to the microphone and the computer picks up the microphone

23 Replies
Highlighted

Make sure that you have the correct device selected in Teams. When you are in the meeting open Device Settings.

Linus Cansby_0-1584620559177.png

 

Make sure you have the correct Audio device selected and also check that it is the same Microphone selected. When you speak you should see the audio meter moving.

2020-03-19_13-21-27.png

Highlighted

@Linus Cansby 

it is the correct device that is chosen in there as well

Highlighted
Yeah i have a very similar problem. I can use the microphone(headset) with other apps like CSGO ,ZOOM and pretty much any app but it does not detect my microphone in teams. Updated drivers, changed input nothing works so i have to use the laptop microphone (which is not the best).
Highlighted

@sun1247 

I have the same problem, but when I changed to custom setup in audio devices options in Teams, it works when I'm testing it with test call. I can't test it with normal meeting at the moment, but maybe it will work for you.

suuupp.png

Highlighted

@Linus Cansby 

 

Hi,

I tried your solution but the microphone field is disabled. I cannot choose any option. Also, I have no options in the audio devices except custom setup.

 

Any other help to solve this problem.

Highlighted

I have the same problem! The microphone of my surface works in Windows itself, Teamspeak, Discord, conferences via browser, only in Teams and Skype it just doesn't work. It's the only mic installed.

Highlighted
It worked when I tried another input but after a little that stopped working too, moved it back to main input and it has worked perfectly since.
Don't know what was going on with my computer
Highlighted

@sun1247 The way I got round this was to use an old Rocketfish USB camera with microphone. Way cheaper than buying a new laptop because I tried everything and couldn't get my built-in laptop mic to work with MS Teams and Skype.

Highlighted

@sun1247   My company updated to Teams on Monday, previously using Skype with no issues but now, my Jabra Evolve 65 headset cuts out my microphone on every single call I've been on, right in the middle of the call.  Error:  "Your microphone isn't working. Switch to a different device or try reconnecting this one." 

 

Our IS department logged on to my laptop, checked all drivers, everything is up to date so it makes NO sense.  I'm currently back on my corded old school headphones with a mic with no issues so far.  I'm using my headset with a USB dongle, so not sure if that's not compatible with Teams somehow?  I'm just perplexed how it works fine for a bit then all of a sudden disables mid-call.  Anyone else?

Highlighted
My problem is that the laptop doesn't detect the headset except I restart it while the headset is connected.
I don't know if this is the same problem or not.
Highlighted

@Manal_El-Khoraiby  My headset connects initially just fine.  I get about 20-30 minutes into a call then a box pops up saying my microphone isn't working, all of a sudden.  I have checked every setting on my laptop and everything is set correctly, as far as I can tell.  It makes NO sense.

Highlighted

@cmlong913 My problem is exactly same with yours. If you have solution for this issue, please share with us. I am frustrating. 

Highlighted

@Rozzzy Hi, just had same problem, all you need to do it take the setting off custom setup

Highlighted

@AndyMac999 Have you succeeded with the solution?

Highlighted
I keep having to mess with settings in the devices section of settings but normally one of the configurations seem to work.
Highlighted
@sun1247 - have you got the fix yet?
Highlighted

@Prerak05 My IT department ended up issuing me a new headphone set, same model and everything and it works just fine now.  Still a mystery why the one I had before wouldn't work but I no longer have this issue.

Highlighted

@Rozzzy Changing it to Custom worked.

It is the the dumbest fix I have ever seen.

So you need to select he actual device from below but on the top you can't select the actual device. You need to choose "custom".

MS... Fix your stuff!

This took me 2 days.

Highlighted

@sun1247 

I found the problem for my headset suddenly not working in Teams.
After a update (Teams, Not Windows 10) I had to give the app permission again.

Hope this helps

DCguy_0-1596750560686.png