SOLVED

App Setup Policy not being applied for one user

Occasional Contributor

I'm stumped. I won't lie. Hoping someone can tell me the stupid thing that I've missed here. I have an App Setup Policy to enable Viva/SP Home Site in Teams. I've placed it at the top left, above Activity. Anyway, I have a policy called Pilot. I use this to test etc. I have two users in the policy. User 1 can see the Button/App - User 2 can't. both are in the same security groups and there's nothing obviously different.

 

We have tried: Removing from the policy, back to Global. Waiting. Re-adding. 

Re-installed Teams

Check Teams online (not showing)

 I've triple checked that the policy has applied and it definitely is. I've completely replicated User 1's config. 

Spudgun_0-1625742459879.png

 

Powershell to apply the policy instead of the gui perhaps?  

 

Any ideas welcome,

TIA

5 Replies

@Spudgun hey ! did you allowed the propagation time to end? it's very common for that to happen and we sometimes forget about the propagation time (it can take almost 48 hours to apply).

Yep. Been working on this (minor but annoying) problem all week now
Are the 2 users added in Active Directory? If they are the exact same and you are applying the same policy, this seems the stranger issue I ever saw! Can you try to add a 3 user and see the result?
Yep, I tried a third user as well and it worked fine.
Since the last post, after another removal and re-add to the policy seems to have worked, although still not perfectly. Now the app is available to the user - he's able to pin the app to the side bar, but the Setup Policy hasn't taken effect because it's not in place permanently at the top where it should be. I'm now just waiting to see what happens. *shrug
best response confirmed by ThereseSolimeno (Microsoft)
Solution
Let's just give at least 48h for the propagation time and then check if everything is 100% or not. If not, really seems the issue is with this specific user so I would advice you to open a case for the Premier Support and from my experience, the case will be escalated internally to check the back-end. Any help needed, please reply me back !