Issues with Modern Attachments (and Add-Ins) in Outlook for Mac

Steel Contributor

Anyone else having problems where they can't attach a file in Outlook 2016 for Mac 15.30 (fast insider build).  Outlook either hangs or crahes.  When I reopen it, ofter time modern attachments are no longer working and Outlook is back to standard attachments.  Eventually it comes back...sometimes after a reboot, sometimes after closing/opening outlook sometimes, before I've even had to wait for an update.


This also goes hand in hand with the new updates to Add-Ins for Outlook.  If Modern attachments isn't working neither are they and vise versa.  Open support issue with MS via the help menu in Outlook for Mac, but guess what...if Add-Ins don't load, neither does the ability to continue the conversation within the help menu.  So while I have a dialog open to try to get support on the issue, I can't back to it :)


Just curious if anyone else has seen similar behavior or has any ideas what might be going on.



12 Replies

Hi Ben, thanks for reproting this issue. I am a PM on the Mac Outlook team and would like to help you with this issue. Seems like your Insider Fast features are dissappearing and reappearing randomly. Can you help answer the following questions?


  • Can you run this command, both when you do have access to these features, and when you dont and reply back with the results?
    • Open Terminal and type "defaults read ~/Library/Preferences/ ChannelName" without the quotes.
    • Reply back with the output.
  • Do you have multiple installs of Outlook or other Office apps?
  • When you run into this issue, are you connected to the internet? Or are you working offline?


Thanks Ben!


Faisal Jeelani | Outlook for Mac PM


     Thanks and definitely!  I haven't been able to get the Insider Fast Feature to re-appear since my last crash a few days ago.  As for the questions.


1. I ran the command when I don't have the features and received the following output:

2016-12-19 20:58:26.686 defaults[14439:624363]
The domain/default pair of (/Users/bstegink/Library/Preferences/, ChannelName) does not exist


I then opened up AutoUpdate and the "Office Insider Fast" was off.  It ussually disables itself after a period of time.  When I re-enabled it and checked for updates there weren't any updates availab.le.  I then ran the command again and the folloinw gwas returned:

% defaults read ~/Library/Preferences/ ChannelName



2. I don't have multiple Outlook installs, but I do have all the other apps installed (Word, PowerPoint, Excel and OneNote).  Word, Excel and PowerPoint have all been fine.  OneNote has been crashing a few times a day on me, but I also have experimental features enbaled right now in OneNote :)


3. It's always been when I'm connect to the internet as far as I can remember (It's rare that I'm not connected :))


Thank you and let me know if you need anything else.



Of course after not working for a few days everything came back tonight.  So, I ran the command again when the Add-In's actually loaded.  The results of the command in the terminal are the same:

% defaults read ~/Library/Preferences/ ChannelName
2016-12-19 23:43:01.693 defaults[28327:883089]
The domain/default pair of (/Users/bstegink/Library/Preferences/, ChannelName) does not exist


One way I can consistantly reproduce the issue is to try to add a file attachment in Outlook, when trying to attach a file Outlook will lock up and ussually when I reload Outlook the File Attachment and Add-Ins won't load.

Here is a crash log from the Outlook Crash that seems to break Add-Ins

Hey Ben, thanks for the details. It looks like we are seeing two issues here.


One where you try to use the new attachments feature (or an add in) and Outlook hangs. You force quit.


The other is when you do force quit and restart, your insider fast features are gone, cause you have been put into the production ring. 


We are investigating both, in the mean time, can you please provide the following - 

When you try to add an attachment, outlook hangs, can you gather a hang sample and send it to us please?

  1. Try to add an attachment
  2. Outlook hangs, let it be
  3. Open Activity Monitor
  4. Select Microsoft OUtlook in the process name column
  5. Click on the gear on the top left, it is a drop down
  6. Select Sample Process and please copy the resulting output and send it here as a text file.


Can you also please send a video if possible? We are not able to repro here so seeing exactly what is going on in the screen may help. If you can't because you have sensitive data on display, I totally understand :)




I'll work on getting that info.  Haven't been able to get the insider feature to show back up yet.  Last time I had to force quit it took about 5 days for something (I wish I knew what) to actually trigger and apparently they just randomly started showing up.


As soon as the insider features show back up I'll work on getting all the requested info.




Hi Faisal, I have a similar problem (lost Insider Fast option).

The result of terminal defaults read ~/Library/Preferences/ ChannelName is:


But I can't see new functions in Outlook and I can't talk with the Support because in deseapper in the Help menu.

It seems like my Insider Fast features are dissappearing and reappearing randomly, in my laptop and desktop.

I have signed again as  Insider Fast in the AutoUpdate program, but NO Support menu appear....



Schermata 2016-12-21 alle 06.35.23.jpgSchermata 2016-12-21 alle 06.35.06.jpg 

Here is the process sample.  Completely forgot to start recording a video.  I'll try to remember getting a video next time.

Got a can't see the spinning wheel, but you'll notice I can pick select different files (it was a spinning wheel the whole time I was clicking on different files) but I'm unable to click Choose or Cancel.



One more update for today.  I just opened up Outlook this evening, and without even have the crash caused by attaching the file all my insider fast features disappered, the modern attachment functionality as well as add-ins.


Thanks Faisal, let me know if there is anythign else I can get you to help.



Hi Ben,


did you ever get to the bottom of this.


I'm having a very similar issue where I have access to some of the insider fast features on one of my machines, but not the other. Modern attachments being one. Google Preview being another.





     In a way...and it wasn't pretty unfortunately.  I was finally able to determine that the issue was actually within my user profile on macOS somewhere.  I ended up creating a temp user profile in macOS and testing that one out for a whild and didn't experience any of the same issues.


Working with MS support, we tried removing my profile in Outlook and creating a new one, uninstalling and reinstalling Office, etc. with no luck.  So, while I'm sure it was still related to somethign in my macOS profile that was created and used by Outlook, we were unable to determine where or what that was.


With this...and some other issues I was having, I eventually just wiped my entire machine.  I probably also could have just created a new user profile in macOS and migrated from one to the other (hoping I didn't pull the issue into the new profile), but at the time, that actually sounded like more work and not as clean as just a fresh install.


Sorry I don't have a better solution, but after doing that, I haven't had anything like this surface again.