Copilot missing in Word, Excel and PowerPoint desktop apps

Brass Contributor

Hi everyone

 

My company has recently purchased some Copilot for Microsoft 365 licenses, one of which was applied to my account on Monday.  If I use Teams desktop app and the new Outlook desktop app Copilot is there and works fine.  I can also use Copilot in the online versions of Word, Excel and PowerPoint.

 

However, Copilot still isn't showing up in my desktop apps for Word, Excel and PowerPoint.  I've checked and we're currently on the Monthly Enterprise Channel and the version of M365 Apps for Enterprise on my machine is Version 2311 Build 16.0.17029.20140, which seems to be the latest version.  This is the same for all our users that have Copilot licenses and they are all experiencing the same issue.

 

I've signed out and back into the Office apps and also checked for any Office or Windows updates but there's nothing that seems to get Copilot to appear in these apps.  The one weird thing I've noticed is that in lots of guides one solution is to go to File > Account in Word/Excel etc and click an Update License button.  However, if I do this I don't see this button:

 

gjayne84_0-1706707061249.png

 

I'm wondering whether this suggests I'm not using the correct version of the Office apps?

 

Any help would be graefully received.

17 Replies

@gjayne84 I have an identical problem.  Enabled yesterday, works in teams and outlook, works in excel/ppt/word online, but not in the desktop apps.  Also, update license button missing.  I assume we have the same issue.

 

I have been looking through our intune configs as we use the STIG baselines, to see what could be blocking it if anything.  Still investigating.

 

Just noticed, my version is different to yours.  We are on Version 2311 (Build 17029.20140 Click-to-Run).  

 

Update:  Just found similar thread and going to try the steps recommended here:  https://techcommunity.microsoft.com/t5/microsoft-365/issues-with-implementing-deploy-copilot-pro/m-p...

 

 

@gjayne84 I’m having the same problem as you.  I am also on a 2311 build, and also don’t see the update license option.  

we do have a lot of policies enabled via intune for various things based on STIG such as blocking the Microsoft store and some restrictions around add ins, so I am going to explore this.  But hoping someone has a clear answer…

Mine is working now. I'm not sure exactly why. I did re-enable the Microsoft Store for my test user. I also allowed store apps to update (dont think this did anything as it was already up to date). I also logged out as my user (sign out from office app in top right, closed all office apps, rebooted). It appears in word now, and powerpoint. Excel didnt appear at first, but now it does. So either a timing issue, or had to sign out and back in maybe. I never got the "Update License" button to show. Also, others suggested adding add-in manually. I never saw it as an add-in in the add-ins store, and I still dont see it there as an installed add-in. Hope this helps.
Thanks for the update and glad to hear it's working now. I've tried signing out and back into the Office apps and also rebooting this morning but still not showing up. I also don't see Copilot as an installable add-in anywhere.

When you say you re-enabled the Windows Store did you reinstall it or just disable access to it for the user and then re-enabled that?
Actually, scratch that I've just tried signing out and back into Word, Excel and PowerPoint and Copilot now does appear. Oddly the icon in Excel is currently greyed out but I'm hoping that will sort itself out in its own time. As far as I know though nothing has changed so as you said I'm assuming it's a timing issue? We assigned some more licenses to users yesterday so will be interesting to see if theirs takes as long to come through to the desktop apps.

@gjayne84 when I say I re-enabled the store I mean we had blocked the Microsoft store for employees through intune.  I made registry changes to enable it on my machine.  I am waiting today to see if another user has word and excel copilot without making the same changes - I suspect it’s a timing issue and may take 24 hours to filter through. 


Excel is greyed out on mine too - I think that’s normal.  You need to create a table (format as table) and then after “thinking” a little bit it un-greys.  I found it isn’t greyed out as long when I open an older doc that hat was already saved in teams/ OneDrive / sharepoint.  

thanks!

Yeah I think you might be right as we've had other users where it's started appearing and we haven't changed anything for them. It's quite random though so some users get it appearing in all apps but some only get one or two to start with. To be honest I'm not entirely sure what's happening in the background to make the Copilot functionality appear in the desktop apps so it's going to be hard to give users timeframes as to when they can expect it to appear.
I have a copilot license on one of my work accounts and on my personal account. I am signed in to multiple accounts in Office. I have to make sure a document is in the right place (correct OneDrive folder to match the license) and that I am using the right account, but even then, it feels a lot like old USB days of plug and pray to see if it will show up.

@gjayne84 What I did was [Update License] under account,. After restart Copilot was there

@Erik_Avegaart I don’t think this update button is there on the enterprise monthly channel.  It worked on mine and another system after about 24 hours.  

I am now on Enterprise monthly, but i used to be on current in the past, maybe that explains why I have the button

@Erik_Avegaart "Update License" results in "Error Code: 44", additional M365 accounts removed, but "Error Code: 44" persists. Interesting to hear if other faces this too.

That's fantastic news! It sounds like your company is investing in boosting productivity with Copilot for Microsoft 365. Here's a breakdown of what you can expect:

Accessibility: Since your account has a Copilot license, you should be able to access Copilot features in several applications:

Desktop Apps: Teams and the new Outlook desktop app should have Copilot functionality readily available.
Web Applications: Copilot should also be integrated with the online versions of Word, Excel, and PowerPoint.
Functionality: You can leverage Copilot's AI-powered assistance in various ways, including:

Enhanced Communication: Improve your writing in emails and messages with suggestions and summaries.
Data Analysis: Gain insights from your data in Excel and create visualizations with Copilot's help.
Presentation Creation: Craft impactful presentations in PowerPoint with Copilot's creative suggestions.
Tips to Get Started:

Explore the Interface: Take some time to explore the Copilot interface within each application. It might be a menu option or a sidebar depending on the app.
Review Documentation: Microsoft provides helpful documentation on Copilot features and functionalities. You can search for "Copilot for Microsoft 365 user guide" online.
Experiment and Learn: Don't be afraid to experiment with Copilot's suggestions and see how it can streamline your workflow.
If you encounter any issues accessing Copilot features, you can check with your company's IT department for troubleshooting assistance.

I hope this helps! Enjoy using Copilot and let me know if you have any further questions.

@Frank Falvey Are you saying then that Copilot is NOT available in the desktop versions of Word, Excel, and PowerPoint? 

Yes, Microsoft 365 Copilot is available in the desktop versions of Word, Excel, and PowerPoint, provided you have an eligible Microsoft 365 subscription. Here’s a more detailed guide on how to get it:

Check Subscription Eligibility:

Verify that you have a Microsoft 365 subscription that includes access to Copilot. Typically, this feature is available in specific business and enterprise plans.
Update Microsoft 365 Desktop Applications:

Ensure your desktop applications (Word, Excel, PowerPoint) are updated to the latest version:
Open any Office application (e.g., Word).
Navigate to File > Account.
Click Update Options and then select Update Now.
Enable AI Features:

If Copilot features are not automatically enabled, you may need to enable AI features in the application settings or through the Microsoft 365 admin center.
Access Copilot:

Look for AI-related features or icons in the Ribbon or help sections of Word, Excel, and PowerPoint. Copilot will typically appear as suggestions, automated content generation, or data analysis tools within these applications.
Admin Configuration:

If you are using Microsoft 365 in an organizational context, ensure your IT admin has enabled Copilot features for your account through the Microsoft 365 admin center.
Steps to update desktop applications:

Open any Microsoft 365 desktop application (e.g., Word).
Go to File > Account (or Office Account).
Select Update Options.
Click Update Now.
By following these steps, you can ensure that you have access to Microsoft 365 Copilot in your desktop versions of Word, Excel, and PowerPoint.