Microsoft Technical Takeoff
Nov 27 2023 07:00 AM - Nov 30 2023 11:30 AM (PST)
Microsoft Tech Community
LIVE

Windows 11 Networking fails asking for Credentials

Copper Contributor

The issue I'm having is with Windows 11 networking and accessing a computer on the LAN using it's UNC name, which in my case is my primary computer running Windows 10 (PROMETHEUS) and my secondary computer (SORCERESS) running Windows 11. Both computers sign in at startup using the same Microsoft Account.

 

The trouble I'm having is if I open Explorer in Windows 11 using <WINDOWS>+<E> (or via a desktop or taskbar shortcut) and then directly enter "\\prometheus" into the address bar, it will sometimes allow access to the computer on the network, and other times it will ask for login credentials and fail:

Type computer UNC NameType computer UNC Name

 

Network credentials fail.Network credentials fail.

 

If on the rare occasion that the connection is made using the UNC path, and I can map a network drive, the network drive might not automatically reconnect at startup because of the same error.

 

But if I enter the IP Address for PROMETHEUS as "\\192.168.1.3", then I can browse the network without problems and correctly maps network drives:

Browse the network using IP AddressBrowse the network using IP Address

 

In network folderIn network folder

 

One might think this is a configuration issue on the Windows 10 machine regarding file sharing. I do not believe so, as other devices on the network (mixed between Windows 10 and Android) can access the PROMETHEUS computer without issues using either the UNC Name "\\prometheus" or the IP address "\\192.168.1.3".

 

This problem about credentials appears only when I'm trying to access PROMETHEUS from SORCERESS which is running Windows 11:

SORCERESS running Windows 11SORCERESS running Windows 11

 

8 Replies

@Dzomlija 
I was having a similar problem, this site helped me as the credential manager was caching some credentials which were not valid.

Enter network credentials error on Windows 11/10 [Fixed] (thewindowsclub.com)

Once I cleared the offending credentials and re-tried I got access to my shared resources without requiring a login. 

 

 

 

@Dzomlija 

 

I'm having the same issue. Using name sharing doesn't work, Example "\\Name\NetworkShareFolder". Using an IP address, Example "\\192.168.1.40\NetworkShareFolder" does work sometimes but not always. The only way I can get it to work every time is to enter the IP Address into Credential Manager with the user and password.

Glad to see I'm not the only one with this issue.

@JoelEL I currently have the same issue. I found when connecting to the IP, credentials worked. I checked IP6 and found it enabled. To test I disabled it which seems to have fixed the issue... but will wait and see if that fix holds. Why would IPV6 cause credential issues? And strangely, only when you try to use the password, entering the "hello" pin works.

@aloney1980 , @JoelEL 

 

The issue seems to have resolved itself. I can access Windows 11 and Windows 10 machines from either OS now using SMB conventions "\\COMPUTERNAME" or IP assignments "192.168.1.xxx". 

 

It works both with IPv6 either enabled or disabled.

 

How or when the problem was resolved, I cannot say, although I assume it happened with a Windows Update. The following screenshots show my current OS versions and builds:

 

Screenshot 2023-03-09 080659.pngScreenshot 2023-03-09 080819.png

@Dzomlija 

 

Regarding your last message dated 5/08/2023 that indicates the problem you discusses previously (that Windows 11 Networking fails when asking for credentials) was resolved.  

 

That issue is alive and well and afflicting all kinds of users including me as of 5/16/2023.  It comes and goes; mostly it comes.  The guidance provided by Microsoft is useless; the guidance provided by others less so but still ineffective.  Based on internet comments that I do not understand I believe the problem is related to the dropping and/or changing of workgroup usage between Windows 10 and Windows 11.  Which means, of course, that the problem can only be corrected by Microsoft.  In the meantime we users only have access to work arounds that are intermittent at best.

 

Mike

@MichaelSpencer 

 

I'm a home user encountering this exact problem trying to connect another PC on my network. Both machines Windows 11 and updated.

@Dzomlija What will work every time, as a workaround, is to connect to a network share on another machine or NAS using the NET USE command.

 

net use <DRIVELETTER> \\<HOSTNAME OR IP-ADDRESS> /user:<USERNAME> <PASSWORD>

 

Formerly you could make this a persistant connection, but this seems no longer possible. Windows 11 will display an error at startup that the network connection has failed and asks you to enter the credentials again after a reboot. To solve this I put the command in a batchfile, called it connect_nas.bat, and saved that in the Windows startup directory. Go to the the location of the startup directory by running this command:

 

shell:startup

 

Now everytime my Windows 11 pc boots it will issue the command and connect the driveletter to the share of my NAS.

You say the solution is to write a shell script to solve this problem that has been around for 6+ YEARS??? In both Win-10 AND Win-11 (and possibly Win 8.1 also)
This is ridiculous/silly.
So now the average Windows user who is increasingly using folders on another PC on their LAN, must learn Windows command level scripting?
I did all this 10-15 years ago to network properly in Linux. Now, in 2023 I must do it in Windows ELEVEN?

FWIW, I am using networked USB storage folders on Raspberry PIs and my ROUTER.

I can now access the Raspberry data OK, but can no longer access the 512GB SSD on my router!

I've had this problem before. MANY TIMES!

MY previous solution a few months ago was to shut down the Credential Manager and reboot.  But this time it did not work.  It must be one of the 9 other solutions to this annoying problem well documented in various tech websites across the 'net.  I'll have to now go thru them ONE by ONE!
And MS refuses to come up with a clean solution.