Cant fully remove user profile Win10 Enterprise V2004

%3CLINGO-SUB%20id%3D%22lingo-sub-1689968%22%20slang%3D%22en-US%22%3ECant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1689968%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%20everyone%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EFor%20years%20I%20have%20been%20able%20to%20recreate%20user%20profiles%20by%20rebooting%20the%20machine%20and%20then%20going%20to%20control%20panel%20and%20opening%20up%20the%20list%20of%20user%20profiles%20and%20deleting%20it.%3C%2FP%3E%3CP%3EI%20would%20then%20confirm%20no%20trace%20of%20profile%20in%20registry%20here%3A%26nbsp%3B%3CSPAN%3EHKEY_LOCAL_MACHINE%5CSOFTWARE%5CMicrosoft%5CWindowsNT%5CCurrentVersion%5CProfileList%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ENow%20when%20I%20attempt%20this%2C%20things%20like%20recycle%20bin%20is%20still%20full%20and%20some%20onedrive%20files%20are%20left%20behind.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWe%20suspect%20the%202004%20update%20may%20have%20altered%20how%20to%20recreate%20profiles.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EDoes%20anyone%20know%20how%20to%20solve%20this%3F%20I%20have%20tried%20on%202%20different%20machines%20with%202%20different%20users%20with%20no%20luck.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%20in%20advance.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1689968%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2004%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eprofile%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Ewin10%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1704337%22%20slang%3D%22en-US%22%3ERe%3A%20Cant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1704337%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F800924%22%20target%3D%22_blank%22%3E%40pmgoes%3C%2FA%3E%26nbsp%3B%20Is%20there%20also%20an%20entry%20left%20in%20the%20profiles%20list%20in%20the%20registry%3F%20Do%20you%20get%20an%20error%20in%20the%20Control%20Panel%20applet%20or%20does%20the%20profile%20get%20removed%20per%20the%20app%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1705731%22%20slang%3D%22en-US%22%3ERe%3A%20Cant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1705731%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F253975%22%20target%3D%22_blank%22%3E%40warrenw%3C%2FA%3E%26nbsp%3BThere%20are%20no%20entries%20in%20the%20registry%20and%20the%20profile%20does%20get%20deleted%20when%20removing%20it%20via%20the%20control%20panel.%20I%20also%20confirm%20that%20the%20folder%20is%20gone%20in%20C%3A%5Cusers%3C%2FP%3E%3CP%3EOne%20thing%20I%20have%20noted%20is%20that%20in%20the%20control%20panel%20the%20profile%20is%20listed%20as%20unknown%20user%20but%20when%20I%20delete%20it%20the%20users%20folder%20disappears%20in%20the%20C%3A%5Cusers%20folder%20so%20I%20know%20i%20have%20removed%20the%20right%20one%2C%20also%20it%20was%20the%20only%20large%20profile%20in%20control%20panel.%3C%2FP%3E%3CP%3EI%20have%20tried%20this%20recreation%20of%20a%20profile%20several%20times%20for%20both%20affected%20users%20but%20dont%20manage%20to%20get%20anywhere.%3C%2FP%3E%3CP%3EWhen%20they%20log%20back%20in%20the%20recycle%20bin%20is%20still%20full%20and%20I%20note%20with%20the%20new%20profile%20auth%20problems%20in%20office%20365%20appear%20as%20everytime%20we%20try%20to%20sign%20in%20with%20their%20account%20we%20get%20a%20white%20box%20and%20cant%20go%20further.%3C%2FP%3E%3CP%3EIts%20quite%20annoying.%3C%2FP%3E%3CP%3EI%20have%20recreated%20profiles%20for%20years%20with%20no%20issue%20but%20we%20are%20wondering%20if%20something%20is%20different%20with%20version%202004%2C%20perhaps%20there%20is%20another%20step%20somewhere%20that%20needs%20to%20be%20followed%20since%20this%20update.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1705823%22%20slang%3D%22en-US%22%3ERe%3A%20Cant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1705823%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F800924%22%20target%3D%22_blank%22%3E%40pmgoes%3C%2FA%3E%26nbsp%3BWhat%20version%20of%20Windows%2010%20are%20you%20using%3F%20Are%20these%20hardware%20based%20devices%20or%20Virtual%20Machines%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20auth%20issue%20in%20Office%20apps%20may%20be%20due%20to%20the%20Web%20Account%20Manger%20service%20not%20starting.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIs%20it%20just%20these%20two%20users%20or%20are%20other%20users%20impacted%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1705843%22%20slang%3D%22en-US%22%3ERe%3A%20Cant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1705843%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F253975%22%20target%3D%22_blank%22%3E%40warrenw%3C%2FA%3E%26nbsp%3BThese%20are%202%20physical%20machines%20that%20both%20had%20their%20profiles%20recreated%20for%20different%20reasons.%3C%2FP%3E%3CP%3EThey%20are%20running%20Win%2010%20Enterprise%20version%202004.%3C%2FP%3E%3CP%3EIt%20is%20only%20these%202%20machines%20as%20these%20are%20the%20only%20ones%20we%20have%20recreated%20user%20profiles%20for.%3C%2FP%3E%3CP%3EIts%20interesting%20that%20this%20auth%20window%20(assuming%20that's%20what%20it%20is%20as%20its%20blank)%20only%20started%20happening%20after%20the%20profile%20was%20recreated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20will%20see%20about%20that%20service%20not%20running.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1706415%22%20slang%3D%22en-US%22%3ERe%3A%20Cant%20fully%20remove%20user%20profile%20Win10%20Enterprise%20V2004%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1706415%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F253975%22%20target%3D%22_blank%22%3E%40warrenw%3C%2FA%3E%26nbsp%3BI%20just%20confirmed%20the%20service%20is%20running%20as%20well%20so%20unfortunately%20thats%20not%20the%20cause%20of%20the%20white%20box.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

 

Hello everyone


For years I have been able to recreate user profiles by rebooting the machine and then going to control panel and opening up the list of user profiles and deleting it.

I would then confirm no trace of profile in registry here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList

 

Now when I attempt this, things like recycle bin is still full and some onedrive files are left behind.

We suspect the 2004 update may have altered how to recreate profiles.

Does anyone know how to solve this? I have tried on 2 different machines with 2 different users with no luck.

 

Thanks in advance.

12 Replies
Highlighted

@pmgoes  Is there also an entry left in the profiles list in the registry? Do you get an error in the Control Panel applet or does the profile get removed per the app?

Highlighted

@warrenw There are no entries in the registry and the profile does get deleted when removing it via the control panel. I also confirm that the folder is gone in C:\users

One thing I have noted is that in the control panel the profile is listed as unknown user but when I delete it the users folder disappears in the C:\users folder so I know i have removed the right one, also it was the only large profile in control panel.

I have tried this recreation of a profile several times for both affected users but dont manage to get anywhere.

When they log back in the recycle bin is still full and I note with the new profile auth problems in office 365 appear as everytime we try to sign in with their account we get a white box and cant go further.

Its quite annoying.

I have recreated profiles for years with no issue but we are wondering if something is different with version 2004, perhaps there is another step somewhere that needs to be followed since this update.

Highlighted

@pmgoes What version of Windows 10 are you using? Are these hardware based devices or Virtual Machines?

 

The auth issue in Office apps may be due to the Web Account Manger service not starting. 

 

Is it just these two users or are other users impacted? 

Highlighted

@warrenw These are 2 physical machines that both had their profiles recreated for different reasons.

They are running Win 10 Enterprise version 2004.

It is only these 2 machines as these are the only ones we have recreated user profiles for.

Its interesting that this auth window (assuming that's what it is as its blank) only started happening after the profile was recreated.

 

I will see about that service not running.

Highlighted

@warrenw I just confirmed the service is running as well so unfortunately thats not the cause of the white box.

 

Highlighted

@pmgoes Thanks for the reply. 

 

To recap 

Profiles show as "unknown" in the Control Panel app.

 

After you delete the profile using the Control Panel System The user profile directory is gone from c:\users and from the profiles list but after you delete the users profile.

 

They log back on (which recreates the profile) and notice the Recycle bin is full and Office apps are seeing a white box when they are launched. 

 

So far we do not have other reports of this behavior and I cannot reproduce the problem.  2004

 

What OS version did you upgrade from?

Are the machines in an AD domain? or Azure AD joined? 

When you reboot and logon to delete the profiles do you logon as a local admin on the workstation or use a domain account that is a local admin?

Are these virtual machines or hardware based?

Do the files in the recycle bin belong to the logged on user? If so, were they recently deleted by the user? Are they from the c: drive or another drive? 

 

It would be good to try a clean boot to see if the issue happens then.

Test if the issue reproduces on a new user on the same device. 

 

 

 

 

 

Highlighted

@warrenw Hi Thanks for the follow up.

They are physical machines and we were running Windows 10 Enterprise and the version was whatever is before version 2004.

We are on An AD domain that is a hybrid of Azure and Local AD, we have no roaming profiles only a folder redirect of desktop and documents. 

The files in recycle bin are users files, I am not sure of the dates and will need to check.

When we were recreating the profile we have tried it off the vpn and also on the vpn (all our staff are working remotely due to covid)

 

The account used is a local admin account.

Thanks for the advice, I would like to try another user on the same device but cant as neither user affected by this is in the office so we are doing this via Teamviewer. 

 

We are getting close to just couriering a new machine to both users though as the impact to their time is getting too high. If I used another user account remotely it would test it but it would be more interruption to the user. As we have tried recreating 2 users on two different machines I think it is likely the issue would happen with another account also.

One user is in the UK and has a new laptop now that we will setup. The other user is here in Australia but I dont think I can really do anymore testing with him. We may have to get him a new machine too.

If there is anymore things we can try on the final user I am happy to test it but think testing with other user accounts on his machine would impact him too much seeing he has already been interrupted so much.

Highlighted

@pmgoes 

We had the same problem, we even stumbled upon a Critical Error when attempting to open the Start Menu after the same user that had just been removed signed back in again. I figured it must have something to do with the User GUID, so I searched for that in the registry and removed most instances. I then created a DOS batch script to make it easier the next time. Here it is. Feel free to adjust to your needs.

 

REG ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit" /v "LastKey" /d "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList" /f 
start "" regedit
Msg * "Copy the the correct Profile GUID from the Registry Editor and close the Registry Editor, then paste the Profile GUID in the batch script"
SET /P PROFILE_GUID="Please paste the GUID "

REG DELETE "HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Deployment\AppExtension\windowsudk.storage.registerschema\%PROFILE_GUID%" /f
REG DELETE "HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Deployment\Package\*\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IdentityStore\Cache\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WcmSvc\wifinetworkmanager\features\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppReadiness\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\%PROFILE_GUID%" /f
REG DELETE HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserTile\ /v %PROFILE_GUID% /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\DataStore\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\State\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\Status\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileService\References\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WlanSvc\ProfileSync\PerUser\%PROFILE_GUID%" /f
REG DELETE "HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\DeviceIdentities\production\%PROFILE_GUID%" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\%PROFILE_GUID%" /f
explorer "C:\Users"
Msg * "Shift+Delete the User Folder and then the Profile Removal is all done"

 

Highlighted

@GreatToHearFromYou Thanks very much for that information.

Its quite unusual for this to happen, its 2 from 2 attempts. The other user is overseas and a director so we couldn't spend anymore time on it so she is using a new laptop now.

For the remaining user it will be up to my boss if he wants anymore time spent on it now but I will keep this handy either way as it may happen again.


Thanks again

Highlighted

@pmgoes You're very welcome. I really think this is a new problem in v2004, I've never had this problem before. I am not sure how long your company is using the 2004 version now, but we just started deploying v2004 for only new computers, or computers that are showing problems and I've already encountered the problem twice, so 2 for 2, thus currently 100% fail rate. The first time it happened to the VP of HR so I couldn't investigate more (just like you), The second time it happened while setting up a new computer, that gave me more time to investigate and come up with the script. I've been helped so many times by the Tech Community, so it is nice to pay it forward :) :thumbs_up:

Highlighted

@GreatToHearFromYou  @pmgoes  Thanks for posting more information to the this thread.

@GreatToHearFromYou  Are you also using folder redirection for any folders? Are you using the control panel app to delete the profiles or deleting them manually? 

Highlighted

@warrenw We do use folder redirection, but only for computers deployed to our Shop Floor, not on any Office computers. Both times the profile rebuilt was done (and failed) was on Office computers.

 

We remove them manually by either Deleting or Renaming the User Folder and then removing the User Profile GUID from the ProfileList in the Registry. However, it seems like @pmgoes does use the Control Panel and is facing similar issues.