SharePoint Online - Cannot move folder to a different site

Iron Contributor

I'm trying to use the 'Move To' function to move a folder to a library on a different site. Typically, I select the folder, click "Move To", and select a site from the information panel. Today I see the following message, "Move 1 item" - the folder name - 'additional destinations are available for moving smaller items". However the only option I have is the current library. There is no sites list or even other libraries as options for destination. 


(we are a current release tenant, however I am a first release user). Any advice? 

44 Replies
Hello Kimberly,

Are you sure that the panel is being rendered correctly?
If yes, you could try Copy To. More on the differences here:

If you have set up a OneDrive Client you could sync the contents of the library and then sync to the Destination folder. I know if seems like an old-fashioned solutions, but it might be a quick workaround.

You could also setup SPMT, choose source and destinations and let SPMT handle the file transfer. More on this subject here :
Just had a report of a similar issue in our tenant. Doesn't look like the copy/move limits we're changed and the files in question are large(ish) but well under the 2 GB limit. Still hunting this down.

@microdot187 I've only had this happen in one library to this point. On a different library, same site, the 'Move to' and 'copy to' function works as expected, with the panel rendering properly. It was a single folder with less than 500 files in it where this new UI showed up. 


(Side note: I ended up moving the files using the ShareGate software which I have from a previous tenant to tenant migration)

I think file size might have something to do with this. I typically move many folders at a time without issue. If I grab 8 folders (with many files), now I get a different message in the panel, instructing me to select fewer items (image attached). If I select a single folder, the panel shows the 'other sites' as a destination option. 

@Kimberly Roetman same thing just happened to me. I copy a synced backup of our student management database to a different library in the same site every Wednesday morning and have been for 2 years now, until today. The files are around 7GB and several sub-folders. If I have to copy smaller subsets that's going to be a pain. I just tried copying one of the smaller folders and it brings up the usual panel on the right. So now I'll have to create a bunch of folders first then copy the larger folders several bits at a time. I'm going to raise a support request.

@Alan Birch Thank you! I'm relieved to know that I'm not alone, but really bummed if this change is permanent. I've moved thousands of files with the simple 'move to' function in the past without issue. 

i just raised a support ticket for this for our tenant. Hopefully we'll have an answer or a new strategy!



Similar issue found that within a subfolder I had 1000 image files. Tried deselecting thinking maybe it was a corrupt file. Come to find out if I select 139 image files I get the same message as soon as I drop to 138 move shows the other sites. I think its one of the bugs. I was then able to deselect all my folder that had images and everything was able to move.

hello do you have any update from MS regarding the ticket you raised@microdot187 

@Kimberly Roetman 


Same issue here.  Any updates from your side?

@Darren Chapman No update yet and not looking like there will be an answer.  Digging around, i moved a bunch of <500MB files into a new Library in the same site, attempted to move to a different site, everything worked as expected, as they are well under the single file 2 GB threshold. So great, does that put me back to looking at errant permissions? Can't be permissions... there's nothing there and that'd have to be a fairly obvious custom permission set that would prevent files >500MB being moved/copied.  


Not that that's helpful, there are thousands of files in this library and these users are just not "techy" enough to abandon that Library, plus they need the metadata for "Created By" and "Created Date" for their operational processes in this particular case. 

Has anyone heard back from Microsoft yet? I have a client suffering with this today. 


I can put in a support request, but just wanted to check any other responses first.



@paulcube6it I just got back to look at versions... if there are too many versions that push over the limit, that could be the culprit. For us, that was not the case, so still working on this with Premier. 



I raised issue with O365 support and was informed this is by design and the Move To and Copy To options can only handle up to 500MB and should use the OneDrive client to move files from OneDrive to Sharepoint Online site.  It used to work fine in the online web portal but now its broken in my opinion.


Was told to vote on the feature request, at 38 votes can't see it being added anytime soon.


This link may of be of use to: Move files and folders between OneDrive and SharePoint

Working with MS on this problem in our new tenant as well. In the old tenant it worked in November.

MS support didn't mentioned such limits as there are site to site Copying/Moving operation requirements:

  • No more than 100 GB total file size
  • No more than 30,000 files
  • Each file must be less than 2 GB


Need to rebuild a full site 200GB in total, 500MB for a bunch of files is crazy limitation.

Also I see another bug that we had this summer: if I try to upload files via SPO site GUI, I need to click upload twice before it will open file explorer to choose files.

Definitely something is wrong with our tenant.

Interesting little update to try... I can't as it's a global setting and would need to go through change control plus the fact that I cannot reproduce this issue in our test tenant, but here's a response from MS... I wouldn't suggest doing this in production of course...

Quoting here...

"So the answer is not what I was expecting. I assume your library is under 30,000 items and the file sizes you are trying to move with the copy function are within service limits. We have the exact same case on a different tenant. I find this difficult to describe so I am working off the article where this is noted.
Allow or prevent custom script - SharePoint in Microsoft 365 | Microsoft Docs
It says you must either allow if not allowed or disallow if allowed Custom scripts on that site. The idea is, the file size is governed by settings or detected as Custom scripting settings. This may be more explicable to you. Does that make any sense?"

@cgsis if that's the answer then so be it, but it changed and now we're left figuring out a new way for our users of who are not paid to be tech savvy... yet another failure of IT to be transparent to the end users. Anyway, thanks for the update, apologies for the gripe.  Happy holiday to you!  

@microdot187 it was the 1st thing that MS support checked. I tried to switch global tenant and site CustomScript settings at my old tenant, and it didn't help. Still waiting reply from MS.

500MB OneDrive move limitation shouldn't be applied to site-to-site or library-to-library move tasks.


1 best response

Accepted Solutions
best response confirmed by Kimberly Roetman (Iron Contributor)

It has been fixed. "Move" works for big files (over 600MB) and many items as before.

View solution in original post