SharePoint Hub Issues - Cross Site Navigation and Associated Sites Not Showing

New Contributor

I have recently had a test communication site converted into a Hub Site on O365 SharePoint. I was then made a Site Collection Admin for the Hub site and another communication site I have been testing, however when I went to associate the communication site to the Hub Site, the option was not there. Thats my first issue.


I then requested to have the Communication Site associated with the Hub Site via Powershell, which was successful. I immediately was able to do a global search across the associated site from the Hub Site. My next problem is with the "Sites" and "News" apps that I added to the page. They quite simply do not show anything, and when I try to configure them to target specific associated sites, there is nothing there (yet I can see the associated site in the search bar). The associated Site is not showing the global cross-site navigation bar either.


Is this an issue based on the permissions setup? The main Admin user (who has/should have access to everything) that is the go-to guy in the business is also having the same issues explained above.


Any help would be greatly appreciated. At the moment we are only seeing a small amount of the benefits that the Hub site could bring - It would be amazing to unlock the full hub site feature set!



7 Replies
best response confirmed by Jason Harris (New Contributor)
These odd issues are usually cause by one of two things. Your users including you and the other admin do not have read permissions assigned to the root site collection of your Sharepoint instance. If your hub or joined sites are group connected sites you need to add yourself as a member in addition to being an owner on those groups. One of those two things should hopefully fix the issues.

Hi Christopher,


You are right - As soon as I was given the read permissions on the Root Site Collection the issue around not seeing  the additional Hub Site features was fixed. That's something to bare in mind when launching the Hub Site to the whole company!


I was also able to find out why I was unable to associate sites even though I was a Site Collection Admin. Basically, the site I was trying to associate was a decendent of the old SharePoint 2013 version (on premise). That meant that the Site was not a Modern Communication Site type. When I created a brand new Site from scratch on O365, I was instantly able to associate the site (so I have some work to do to migrate the content over - but I will now get the chance to properly work out the entire Intranet Hierarchy... Silver Linings!).


My issues were a mixture of permissions and legacy SharePoint (intranet) sites. Anyone having similar issues, I would suggest checking the Root Site Collection (as 9 times out of 10, the O365 SharePoint issue will be down to permissions!).


Thanks for your help with this Christopher!

Hi Christopher (or Jason), Can I ask you a quick follow up on this? I had what I think is the same issue, whereby I have registered 2 site collections to belong to my Hub Site, and the nav bar showed up no problem. Now, a couple of weeks later, I have registered 3 more Site Collections to my Hub Site and on not one of them has a Nav Bar appeared. I've tried via the Admin console (as I did it successfully the first time) and I've also tried with Powershell in case that kicked off something. But nothing. One of the new site collections I registered had a green theme and as soon as I registered it to the blue Hub Site it took on the blue theme. But still no nav bar. I've read your post and as a result I've added myself as an individual to the Members group in Site Permissions, but still nothing (I'm also a Site Admin Coll on the lot as well as a Owner). Any thoughts?




I think I have a similar issue.

I am the owner of a Hub site, and I have just been made owner of another site (let's call it site B) but when I click on the cog then 'site information' for site B, I can't see the 'Hub association' field, just a spinning wheel as if something was loading. The same happens if I look at my Hub site information.

But I have site C, which I have created and am an owner of, where I can perfectly see the 'Hub association' field.

I can't see any obvious difference in permissions between site B and site C.


How do I add myself as a 'member' in addition to being an owner as you suggest? Do I click the cog, 'site permissions' then 'share site' and add my name again with 'edit' rights? Will that nor overwrite my ownership rights?


This was me being dim. I didn't realise when I wrote this that the nav bar only showed up on modern pages. The homepages of the sites I had associated with a hub had classic homepages. As soon as I navigated to a modern page the nav bar showed up.

@Jason Harris I have noticed this as well in my Dev tenant, and not sure what's affecting it. All my sites are modern sites, either Team or Communication sites. Whether I associate a site to a hub from the SharePoint admin portal, or via the actual site, in all cases the linked site is not appearing in the hub site navigation. I am the owner for all these sites, so it's not a permission issue. 

I also don't quite 'get' why there is the ability to edit or add hub site links (unless of course they are very long site names). If you add a link, this is not a hub site and that gets confusing. 

Anyone have any suggestions why my associated sites do not appear in the hub site navigation - see images.