Power Automate - Approval Flow getting stuck in Limbo

Brass Contributor

Hello everyone,

 

I'm currently using power automate's, what I can only describe as, "an out of the box" approval flow (its the option you get when in the modern view of a SharePoint site). Problem is, recently the flow itself has started breaking in that, I get notified of the approval request (a site page edit) I click on the view page link to see review the change and actually approve or reject the page, all I can see is an empty panel telling me that I don't have any approvals:

 

Corbenik_0-1680552617802.png

 

Looking at the power automate's history, I can see that I now have 10 or so pages to be approved and the flow for them has been running for days...

 

Corbenik_1-1680552842041.png

 

 

Any thoughts on what might be happening? There's no 'Fail' or breakages per se, it just seems to be stuck so I can't really tell what might be happening and I'm wondering if anybody here has dealt with a similar situation?

 

5 Replies

@Corbenik Are you trying to see Approvals from here or from somewhere else? 

ganeshsanap_0-1680591338517.png


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

For SharePoint/Power Platform blogs, visit: Ganesh Sanap Blogs

@ganeshsanap nah from the page itself:

 

Corbenik_0-1680645398631.png

when it works you just go into that 'Review approvals' button, the side panel will come up where you would then have the option to either approve or reject the changes made. But now all I get is that empty list from my post suggesting that there is nothing to review

@Corbenik I think you are talking about SharePoint out of the box site pages approval - when you enable content approval from library settings > versioning settings. Am I right?

 

In that case, when you click on "Review approvals" button, you should see approval requests for the page in right panel like: 

ganeshsanap_0-1680674388547.pngOr are you using any customized Power automate flow approvals for this?


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

For SharePoint/Power Platform blogs, visit: Ganesh Sanap Blogs

@ganeshsanap 

Yup it is the out of the box one, problem is using the Review approvals button doesn't really show anything for me in any of the three panels (Received, Sent, History)

 

Corbenik_0-1681160384426.png 

Corbenik_1-1681160802466.png  

Corbenik_2-1681160841097.png

 

 

 

@Corbenik I would suggest you to raise a support ticket with Microsoft directly.

 

Follow: Get M365 support - online support 


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

For SharePoint/Power Platform blogs, visit: Ganesh Sanap Blogs