List items not saving in folders

Iron Contributor

Morning all - tearing my hair out with this one!  Here's the scenario:

  1. Using SharePoint Online.
  2. I've created a list using site content types to collect relevant fields of data dependent on the content type.
  3. I've enabled folders in the list so that I can control view / edit access at folder level.

Here's the problem:

  1. I select a folder to go into it.
  2. Click the '+New' button and select the relevant content type.
  3. Complete the relevant fields and click Save.
  4. The list item saves in the root of the list, not the folder I was in when I clicked the New button.

I've also noticed that when I right-click on a folder there's no 'Rename' option as there would be in a Document Library.  There's an Edit option which shows the path and folder name, but no option to change it.  It's as if the list is treating the folder as a list item and not a folder.

 

I really hope someone can help as this is causing me real headaches!  Thanks as always.  Oz

7 Replies
Hi Oz,
sharepoint doesn't allow to rename the folder using right click option, but you can rename the folder using quick edit option.
Then regarding you actual problem, i would like to know how you created the content type? is it created pragmatically or using site content type from site setting, but in both option my new items are placing where i am creating the item.

@Thivagar_Segar , thanks so much for the quick reply.

  1. Folders renamed successfully using Quick Edit.
  2. To create the content types I did the following:
    1. Site Settings > Site Content Types
    2. Create
    3. Used List Content Types > Item as parent (not sure this is correct as I'm not that familiar with using Content Types) and put it in a New group.
    4. I've then created all the required columns in the List settings
    5. Again under List settings I opened each content type and selected the columns I wished to include

Really hoping you can help as I need to get a prototype out to the business ASAP.

Thanks again, Oz

Hi Oz,
it seems you have created the content type in correct way but i am not sure why the items are getting created at root level.

but i suggest you to have a look on the URL while creating a new item, the url format should be https://tenant.sharepoint.com/sites/sitename/lists/listname/allitems.aspx?id=%2Fsites%2Fsitename%2FL...

you can replace the above url format with your URL and find out what was the URL showing while creating the item.

@Thivagar_Segar - thanks again.  I'll look at the URL now, but just noticed something else strange.  I've renamed the folders using Quick Edit, but when I bring up the Details panel, the original name still shows.  See attached screenshot.  I've refreshed everything and it's still the same.  If I click on the folder to go into it I still see the original folder name at the top as well.

 

Just thought I'd mention this in case it sheds any light on what's happening.

 

Ok then you need to follow some trick to change the original folder name
Use IE for this process..
Step 1: Go to any document library of that site/ site collection and open that library in explorer view
Step 2: In explorer view, navigate to Lists folder ( path should be https://tenant.sharepoint.com>sites>sitename
Step 3: select the respective List name
step 4: Select the respective folder name ( Test_Folder_Name_Original)
Step 5: rename that folder to Test_Folder_Name_New

then refresh you sharepoint page and check the folder details, it will reflect with you new name.

Morning @Thivagar_Segar .  I've checked the URL when creating a new list item from within a folder.  If I'm in "Folder_1" it is

https://<tenant>.sharepoint.com/sites/TestTeam/Lists/Test_List/AllItems.aspx?viewpath=%2Fsites%2FTes...

 

I therefore appear to be in the correct folder when creating the new item, but it still saves to the root.

 

I've tried creating a new list in the same site which doesn't use any content types and the same happens.

I've also tried creating a new list in a completely different site and same result again.

 

This therefore doesn't appear to be a content type or local list settings issue, it's a problem across our tenant.  Thanks again, Oz

Good morning @Thivagar_Segar.  I had several calls with Microsoft last week and it turns out that there was some issue with our tenant.  They ran some diagnostics which fixed the issue and it's now all working as expected with list items saving in the folder you're in.  Unfortunately they're not able to provide a root cause analysis so we'll never know what the specific issue was, but at least it's fixed.

 

Thanks again for all your help and I hope this helps anyone else who may experience this issue just in the modern UI (as classic worked fine).  Oz