~$ in my document's name?

Iron Contributor


I am migrating some documents från a desktop to SharePoint online but I have noticed that in some libraries SharePoint is replacing the first letter of the document's title with ~$ 

If the document title is something like Analysis 2017 it's get saved in SharePoint with the same name but it also creates an empty document called ~$nalysis 2017. 


This happens randomly. 

I have checked the source in the desktop folder and there is no documents starting with ~$ and they are not using special characters in the titles. 

First I thought that has something to do with this specific SharePoint online but I ran a test in Another tenant and suprise I got the same issue.


Why is this happening?


Best regards


2 Replies
How are you migrating those documents? Some other questions:
- Are those documents opened at the source?
- Do you have any hidden files related to those files that could be causing the issue?


My first time I uploaded them using the Sharepoint GUI (uploading the folder from inside the library)

The second time I mapped the library to my desktop and copied the files just like if I was working with normal windows windows

And the last time I used Winmerge. 


The document are not opened at the time I uploaded them. But... they were synced with OneDrive. I got access to the originals documents, which are hosted in a local server, and the people that worked with them used OneDrive to sync theirs copies. The users promised stop working with the files before I begun the migration.