"Outlook data file cannot be accessed" when trying to send from shared mailbox?

Occasional Contributor

We are using shared mailboxes for several purposes, but getting erratic behavior. 

Latest is error when trying to send from Windows Outlook clients. 

Mailboxes are configured in Outlook as an account under local user profile.

Accounts appear and receive email perfectly, and when outbound email is drafted it:

  • Appears perfectly fine under 'Drafts' while in process
  • Appears queued up in Outbox when Sent 

However when send/receive is processed, we get

"Task ' - Sending' reported error (0x8004010F) : 'Outlook data file cannot be accessed.'"


Emails saved to 'Draft' can then be sent by other clients (mobile, web) but will not send those same drafts from Windows Outlook.  For the moment this is the crazy workaround for us. (draft on PC, use mobile to send from Draft...) 


General googling for that error suggests "profile is corrupt" and we should delete everything reconfig, but I suspect this is red herring and not applicable in this case (sounds like the usual "re-install" non-answer time-waster). 


Is this an Outlook config problem?  Are we missing a configuration detail in the account setup for a shared mailbox like this?   


Or can we not add shared mailboxes to the accounts list in the profile like that..?  


We have indeed fiddled around with these shared mailboxes a bit and until we configured them as accounts in the profile like this we were unable to get the "save to" features to work properly (aka any time you drafted emails the Draft and the Sent folders would always be the actual users and not the shared mailbox folders...) but now it seems outbound won't work... 



7 Replies
best response confirmed by ComotoJC (Occasional Contributor)

@ComotoJC, I was able to fix one of my shared email accounts that had the same issues as you describe. I thought I share what worked for me.  I compared the shared mailbox that was not working to a second working shared mailbox and noticed that the working mailbox has two data files compared to the one with the broken mailbox. One is the standard OST, and the second is an NST. After reading this post-, I determined it must be the issue. 


My fix was to remove the broken shared mailbox from Outlook and add it back.  It took Office365 thirty plus minutes to sync up and recreate the data files. Once the sync completed, the broken shared mailbox now had the two data files, and I was able to send an email as the shared mailbox account name.


BTW: Outlook did an automatic restart when it completed the synchronization.


Hope this helps.

@Codewriter93   As much as I wanted to avoid it, I just deleted the whole profile.  Interestingly I could not delete the shared mailbox account from the profile.  Some message about how it had been made the primary and the primary could not be deleted.  Odd because that had never been done (aka that email account had not been made the default or anything).  I ended up deleting and re-setting-up that entire profile from zero, then adding the shared mailboxes, and now everything works perfectly.  I think. 


This is odd because its the 3rd-4th time we have attempted that on this windows client and always had some kind of shared mailbox problems, either the one above or in not saving to the shared Sent/Drafts folders even when doing send-as, but for now its finally working (knock on wood). 

Never mind. Outlook Windows client is a disaster with shared mailboxes for us. Seems 100% impossible to get the Send As to work as intended. Do we really have to do all our Send As via smartphones as a workaround? Unbelievable.

@ComotoJC The one issue that is probably messing you up is the auto-mapping in Office 365. I had to remove all the users from the shared mailbox. I manually entered each user using PowerShell.


Use the cmd --   Add-MailboxPermission "The name of your shared mailbox" -User -AccessRights FullAccess -InheritanceType all -AutoMapping $false     --


followed by the second command --   Add-RecipientPermission "The name of your shared mailbox" -Trustee -AccessRights SendAs -Confirm:$false

You will then have to manually add the mailbox for each user in their Outlook allowing Outlook to sync with Office 365.


If you rely on the automapping to do it all for you it will not work. At least for me.

Agreed the automapping seems to mess things up. Is shocking such a simple frequent feature works so badly with the "flagship" Windows client... When we tried adding the accounts to the Profile thats when I got the original error this thread was about... thought we fixed that with a 're-do' but indeed then we were back to the automapping "default to on behalf" mess.

Microsoft: This is NOT intuitively how people expect this to work! Fix it!

Well it continues to be "Fun". 


Deleting entire profile and reconfiguring worked for a few hours. Then a "Send As" message went to the Outbox but would just sit there, never actually being sent or trying to send.  You could open and edit it as much as you liked but it would never get processed with a Send/Receive. 


What was super fun was that Outlook would see it and warn "are you sure you want to exit with items in the outbox!?!?"... but would still refuse to ever try to send it. 


Shared mailboxes are a disaster. 

This seems to have worked for me! It was giving me some weird issues at first not loading emails, but I made a fresh profile in outlook and added both accounts and it seems good now.