Outlook Password prompt disappears quickly

Occasional Contributor

Good morning everyone,


Over the past several months we've been experencing a very random issue where Outlook loses users credentials, and then when loading Outlook it prompts for the password, but goes away so quickly you don't have a chance to enter the password.


Steps we have taken to resolve the issues.


1. We've cleared credential manager on the system

2. Repaired office (both quick and online).

3. Created new Outlook profiles (including deleting the .ost file).

4. Uninstalled/reinstalled Office completely.


Most times it works itself out after a few days, but I don't get why this issue continues to happen.


Any helpful tips?


thanks in advance

47 Replies



There is a known outage from Microsoft which is still in effect.. 

User Impact: Users may be unable to connect to the Exchange Online service when using the Outlook client.


It started 7/31 - present. The workaround is to use Office online. We have few users report this issue as well.


Are you in a Hybrid setup or Office 365 Exchange online setup? 

@Ash365 are they supposed to release a patch to fix the issue?

@Ash365 I didn't see the last question.


We are Hybrid.

best response confirmed by dhendrix24 (Occasional Contributor)

@Ash365 I was able to resolve this issue by adding the following registry keys



Credit to this article also


  • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, create a DWORD value named EnableADAL and set it to zero.
  • Under the same registry key, create a DWORD value named DisableADALatopWAMOverride and set it to 1
I just want to say that we were stuggling with this issue in our Windows Virtual Desktop environment and this seems to resolved all our problems. Thanks for this post.

We have the same problem on our new WVD system.


Outlook after day or 2 disconnects and says 'need password'.


We managed to go around by putting:"HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, create a DWORD value named EnableADAL and set it to zero." into users profiles.


We don't want to leave it like this as customer might want to switch to 2FA in the future and this will cause problems.

@prelek Have you found any other solution to this issue?  We are having the same issue in a WVD environment and already have MFA enabled.

Nope only fix I've seen is to use the one above. I've seen it about 4-5 times in the last month also.

Found the solution here:


So make sure you:

  1. Fully enable Single Sign On (AD Connect)
  2. Hosts must be Hybrid Azure Joined (in AD Connect)
  3. OU in AD where hosts are should also by synced (AD connect filtering)


@prelek Thank you SOOOOOO MUCH! I've been struggling with this for months! Even Azure/Office 365 support told me to use the registry keys to disable modern authentication. That's NOT a solution! I was on the right path to get it working but was missing the critical piece where the hosts need to be Hybrid Azure AD joined. The moment the hosts showed up as Registered in Azure the "Need password" flickering authentication window issue changed to "Connected to: Microsoft Exchange"!

I had a client that kept having this same issue, even after I did every thing you did. What I found was going on is that she was logged into Outlook under one account and logged into OneDrive and other Office apps under another. Once I logged her out of the other account in OneDrive and the other apps and logged her back into those apps using the same account she used for Outlook the issue had resolved.

Perfect... work for my
It worked!!!! Thank you.
This worked for me. Had InTune, MS 365 corp and personal profiles etc.
I just had to logout of the OneDrive and from MS Office apps and all went back to normal.

Outlook reset the corp profile and had to sync again.

Thank You @Smylez

We have been using this fix as of late. However, new reports show the issue returning. Registry item still in tact. On the new reports, issue goes away randomly on reboots, then returns. So the general population is gonna need more than just this registry fix. :( @dhendrix24 



Hey guys, not sure if anyone else is continuing to have issues with this. As luck will have it, we ran into this same issue and noticed the password prompt would "flash" and immediately disappear as well for Outlook.

Read through this thread and disabling MFA is definitely NOT an option I would entertain.

I noticed End User was not logged into OneDrive... logged user into OneDrive and was immediately prompted afterwards for credentials which resolved the issue with Outlook.

I am waiting to see if we run into this issue again to test it again but just thought I would put this out there in case it is able to help someone.

We had this exact same problem for about 3 users. (out of thousands) and we do not have onedrive enabled for our users nor do we use Hybrid Domain join. 


Any other ideas? other than disabling MFA support? in fact is that all that EnableADAL 0 does ? Is disable MFA support for Office Apps? 




@Robert Bollinger Disabling MFA was not in our list of options. Try the following also: 

  • Have end user close all Office apps
  • Launch MS Word. Go to File -> Account -> Sign out
  • Close MS Word
  • Open it again and you will be prompted to sign in and activate, go through the process and you should be prompted to sign in to Outlook as well when you launch the application.

I understand this is a work-around but I still do not know what is causing the original issue and as I said before, disabling MFA is not one of the options to consider.