Can't create groups in Outlook desktop app

Copper Contributor

Hi everyone,


I can't create groups at the Outlook desktop app. When I try to create one, shows me the following message: "The group can't be created right now. Please try again later".
Although, it is possible to create groups at the Outlook browser version.

Is this a known bug? Is there anyone with this problem?

Thanks in advance.

10 Replies

Seems to work OK here, I'm on version 1908 (11929.20516). Might be a temporary issue or something specific to the version you are using.

Hi @Vasil Michev,

Thanks for your message.
I have this Outlook version:


Hi @Carolina Trigo,


I have tested with the same version as you (Monthly Channel Targeted 1912), and I have the same behavior. Insiders Fast (build 2001)build also has the same issue.
It looks like the first build without the issue is Monthly Channel 1911.

I would say this is a recent bug, and I am not sure if Microsoft is already aware of it. You should open an MS ticket to create awareness.

Both of you should report it, the more "signals" they have the better :)

Thanks for both replies.
We opened a ticket and it really is a bug on this version.
So, in order to fix it, we have created a policy to update the Outlook desktop app to a stable version (version 1912 (Build 12325.20288 Click-to-Run) Monthly Channel). :)


We are facing the same error message on Outlook app when creating an Office 365 group "The group can't be created right now. Please try again later";

we are reproducing the issue on 

Monthly Version 1912 12325.20344


Monthly (Targeted) Version 2001 12430.20184.

Seems that the only workaround for now is to downgrade the office build or switch to another update channel :). In OWA we are able to create a group without any trouble. 



Do you know if this problem has been solved somehow by anyone?  I'm getting the same error message!

@cathyb9999 I'm getting the same error also. Has anyone found a fix? 

I and several members of our company are having the same issue. I think the bug has come back to haunt us.
I have a client having the same issue - is there no fix. I have them doing a current workaround of using Outlook on the web to create groups.