SOLVED

OneDrive Files On-Demand Didn't Start

Copper Contributor

Screenshot 2023-10-22 at 09.34.44.png

Recently moved from an Intel iMac to a M2 Mac mini running Sonoma. Trying to use Onedrive on an external drive with the above error message keep coming up. Initially it work ok for a few days but then this error occurred. Now I cannot get it to go pass this page and only gives me an option to close.

Tried everything without success

 

2 Replies

@rhargey 

I’m sorry to hear that you’re having trouble with OneDrive Files On-Demand on your M2 Mac mini running Sonoma. Here are a few suggestions that might help:

1.Check your file system: OneDrive requires the APFS file system. If you’re using a different file system, you might need to upgrade.

 

2.Check folder permissions: Make sure your OneDrive folder isn’t locked and has the appropriate permissions.

 

3.Restart your Mac: Sometimes, a simple restart can resolve the issue.

 

4.Reinstall OneDrive: If the issue persists, you could try uninstalling and reinstalling the OneDrive client.

 

5.Enable Files On-Demand manually: You can try enabling Files On-Demand manually by typing the following command in Terminal: defaults write com.microsoft.OneDrive FilesOnDemandEnabled -bool true. After running this command, restart your Mac

 

If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)

 

best response confirmed by rhargey (Copper Contributor)
Solution
Thanks very much, option 5 did the trick.
1 best response

Accepted Solutions
best response confirmed by rhargey (Copper Contributor)
Solution
Thanks very much, option 5 did the trick.

View solution in original post