New Distribution List Group won't receive emails from external address

Occasional Contributor

I am having trouble getting a new Distribution List group to work properly.  I have setup in the admin portal under groups the distribution group email/alias, etc, and have checked the option "Allow External Senders to Email this Group".  I verified a couple of times this box is in fact checked. 


Everything is saved and its been a couple hours since setup.


When I send an email from my internal address to the distribution list address, it works fine - the distribution list delivers to the distribution list members.  However, if I send to the list email address from an external address, I get a bounce back error "553 sorry, no mailbox here by that name. ulc: , rcp: 0001. (#5.7.1)" and no message is delivered.  


Does it take time for things to propagate through the DNS or AD or something?  In AD control, the distribution list shows as active and running.  It works fine as I said internally... it just won't work for external email addresses... which is a requirement for what I am trying to do with it. 


Any thoughts or suggestions?  

20 Replies
What are you sending from address wise to the distro group? I've seen many times where people will use a system to test using their own address which is spoofing and it won't allow that through usually or something similar. Assuming you sent form a yahoo or gmail to test?

@Chris Webb  Yes that is correct - I sent the test from a gmail account.  I also had someone else try from a gmail account, same result... but if sent from an internal account, it works like a champ. 

Also how is your mail routing? Are you hybrid? If so you can't create a distro in 365 only and it work from external since your front end devices routing through onprem won't know about it, but internally it will work because it doesn't leave the 365 mail servers. Something like that could be why, how is your end to end routing for mail coming into your o365 exchange instance, mx go on prem through a device to onprem front end into 365 or anything like that?

@Chris Webb  I have no idea... but I have 3 other distro lists setup in the same manner, and they work just fine.  Literally all have the exact same settings.  The other 3 receive mail from external addresses with no problem. It has been a year or so since I set those up, but I just don't recall it taking more than a few minutes to work once set.  It has been the better part of a day at this point and still not working.   


I am happy to check some settings if you have the patience to tell me how to determine how my mail is routed, but I am not an IT guy, just a small business guy with no IT support :).

well, first thing I would check, those groups that work, are they on your on-prem Active directory server in the same OU as the one you just created? Assuming you have an on-prem AD server. That's the first place I would check / find out, cause if you do then your mail may be routing still on-prem somehow. If everything is 365 then not going to be the issue at all.

@Chris Webb I am not exactly sure how it is configured.  We have a virtual server that is hosted offsite, but that would be the same as on prem?  But the source for my users is all 'Windows Server AD'. I attached a screen of the groups.  efax is the new one that is not working... but all show a source of 'cloud'.





Here is a snip of the bounce back I get, not sure if that helps anyone. 


Yea it's not going to be a routing issue then if they are all cloud source. Can you screenshot the message delivery option screen or whatever it is with the "External allowed option?"

@Chris Webb here is the setting in the admin panel:



And if I go to the "More Settings" link, it shows up in the exchange center as below:


Ok, this UI doesn't tell the whole story usually. Go to Exchange Admin center link there, then groups, then the group and on the group window then the Delivery Management tab and screen that one.
I edited above to include; figured you'd want it
Interesting, just saw the bounce message, guess you edited that too. The doesn't seem to be permission related at all. On that same exchange admin box for the group under e-mail options. make sure the e-mail address being used shows up here? Seems like the address itself just isn't working. If it is, I'd create another alias in here. Then try to send to that alias to see if that works and if so, might need to do a swap out of e-mail and back for it to register or something?

@Chris Webb  It does correctly show under email options.  H


ow do I go about creating another alias?  I add a new address under email options?  can it just be any address? 



Any address in your domain. Assume the new group and the other groups all use the same right?

@Chris Webb  Yes that is correct.  All the same domain.


I created the new address (faxbox@...)... same results.  Bounce back from external.  Delivered internal. 

Only thing left I know to try maybe enable internal only. Save it, wait a minute, then switch it back.... otherwise maybe give it overnight or something to see if it's time related although you would think it should be done by now....

@Chris Webb ok, gave that a try, still no joy, was a good idea though, don't know why I didn't try earlier.


I really appreciate your help - I think at this point I am just going to let it sit over night and see if something propagates to make it work tomorrow.  I'll certainly update back here i anything changes.  

Good luck. Other idea might be put an address without fax in the name, maybe there is a spam filter for it somehow. although based on rejection message doesn't seem like it would matter but just grapsin at straws. Save it for tomorrow i guess :p

@Chris Webb @justin1981 

Hi any conclusion here? Experiencing exactly the same issue.






For me it worked removing the "allow external senders" wait 5 minutes enable it again even it was a brand new group