Teams won't launch as a Citrix published app

New Contributor

I previously had Teams installed on my orgs Citrix farm and working on all 8 servers. 

cmd used: 

msiexec /i "\\server\Microsoft\365\Teams\Teams_windows_x64.msi" /l*v c:\temp\TeamsInstall.log> ALLUSER=1 ALLUSERS=1


Unfortunately because our IT department was the only one with Teams at the time, no one really used it from Citrix once it was tested successfully (we used the desktop install or mobile). Months went by and we were getting ready to deploy Teams to the rest of the organization, and when we went to test Teams in the Citrix farm and though it would initiate the launch, it never actually opened. First the Citrix progress window would come up, then the Teams splash screen would come up saying it was installing, but then disappeared after about 30 seconds. The version was a little older, so I uninstalled Teams, then the Teams Machine-Wide Installer, then tried the same process I had done before that worked successfully, but I had the same end result.


If I log into the Citrix desktop, Teams launches just fine. What am I missing??

2 Replies
best response confirmed by adam deltinger (MVP)



Teams on VDI is quite a specialist area. Have you been through the install guides here:


The answer I would give is run though and reinstall using the guides, if the issue persists then raise a ticket Microsoft support and/or Citrix. You could also reach out to known Teams Community VDI specialists such as Patrick Kohler who is pretty visible on social (I would tag him if he were on the tech community). @Alexander Ivanov may be able to help too


Hope that answers your question


Best, Chris

ElizabethV8, please open support case with Citrix.