Teams stuck in a launch+crash loop

Highlighted
MVP

For about a week now, my desktop Teams client is stuck in a loop where it will follow these steps:

  • Teams will start
  • Within ten seconds, it will render the message "There was a glitch and we're recovering"
  • It will restart (repeat ~3x)
  • It will finally show a window that says "There is a glitch. Sorry for the inconvenience. Please sign in again"

Since this bug has occurred, I have been completely unable to use the desktop client. I have attempted to uninstall and reinstall Teams twice at this point.

 

5 Replies
Highlighted

Hi @Sidney Andrews ,

 

Have you tried clearing out AppData locations too, as I know sometimes an uninstall does not get rid of everything.

 

Might also be worth clearing out credentials too.

 

Thanks

 

Henry

Highlighted

@henryarphillips365 I cleared the AppData locations and that didn't work.

I haven't tried clearing the credentials. How would I do that?

Highlighted

@Sidney Andrews 

 

I was personally thinking Windows Credential Manager (assuming you are a Windows user).

 

And for the paranoid in me, I would clear out web credentials for good measure too.

 

Thanks

 

Henry

Highlighted

Hi Sidney,

 

I've also been expericeing the same issue over the last week or so on Windows 8.1 machines only.

 

Setting the "Teams.exe" in compatibility mode for "Windows 7" allows Teams to launch as normal but this is not an acceptable work around for us.

 

Would be good to find the root cause of this issue.

 

@Sidney Andrews 

Highlighted

@Rob_Bones 

I'm on a Windows 10 machine (Build 2004). Setting the executable to compatibility mode for Windows 7 didn't stop the crash loop.