SOLVED

Outlook "Share to TEAMS" comes with a message

Occasional Contributor

I work with several Microsoft Work and School accounts on my laptop. The laptop main account is used on startup windows. The first in Outlook and assigned to the desktop Teams app.

However, when I push the button "Share to TEAMS" in Outlook I get the massage "You need to change your TEAMS to ... and then follows the name of that main account. But my TEAMS is already in that account. So, what is going wrong? And are there more people having this message? 

 

Kind regards 

Steven

25 Replies
Hello, I can imagine that you're experiencing some issues as the credentials most likely are mixed up. That's the main problem using only one device with several accounts (at least today). I think you can sort it out by signing out manually from all active sessions, shut down your running apps and restart the laptop and then sign in with your primary account only.
Thanks Christian. I tried that even 4 or 5 times. But that didn't work. I also consider removing all the extra accounts to see what is happening then. But I'm a consultant and working for several organisation and it is simply not an option to have a device for every client I work for.
I understand. The Share to Teams add-in uses SSO so your issues are most likely related to that.

@Steven van der Bles 

Same issue here..

tried all above but no sollution yet.

 

 

Same issue here.
Anyone opened a support ticket with Microsoft? If so please add to the conversation.
Hi All I do not have as many accounts, but you can solve this by adding to edge browser separate profiles can be many = opening Outlook on the logged-in school profile should not be a problem with synchronisation! and sharing will be properly certified = Of course, adding all accounts to Windows is required! If it will be helpful, please information so then it helps others. Thank you
This is not working. I have most of the times 7 or 8 Edge profiles open.......

@Steven van der Bles You may have to "Quit" Teams and clear the app cache. Logging out and back in or  rebooting your computer isn't enough to do this. After logging out of all of your accounts, be sure you Quit Teams by right-clicking on the Teams icon in the taskbar and selecting Quit.

 

Karen_D17_0-1617987384140.png

This will not only close out Teams, but it will clear the app cache. I suspect it will work after you do this.

NOTE: This works really well for when you see broken image links in your conversations but the images appear if you click on them to enlarge them also.

 

Good luck!

:) Karen

Hello Thank you for your reply! It proposes to ask the administrator of those organisation with whom you communicate to help solve the problem is partly in their competence! access permissions that are blocked sometimes it may be due to ESL - there are probably many unknowns! It is worth talking about this problem - even if we do not find a solution for sure we want to help! Good luck Andrew
best response confirmed by Steven van der Bles (Occasional Contributor)
Solution

@Steven van der Bles 

I did some looking around within Outlook and found out that in my case there are more "Share to Teams" commands available in Outlook. When choosing "Customize the Ribbon" and "All Commands" I can choose from 2. One icon is colored a bit different, the other icon is the same as default shown on the ribbon. This last one doesn't work. The other one does however when adding the "Share to Teams" command to a custom section on the ribbon. Strange.

"Share to Teams" options in "All Commands":

Wim_NL_1-1618064175188.png

 

 

Thanks ! Your solution worked for me.
Thanks, that solution worked for me. I had to completely remove the Teams group in the customize ribbon screen, create a new Custom group and then add the correct Share to Teams icon, but now the feature works!
I opened a case with Microsoft friday but they couldn't resolve the issue after an hour. Still waiting on a call back from them. Thanks!
Thanks - that worked for me too!
@Wim_NL. Thanks for this solution. It works for me :)

@Steven van der Bles 

 

I had a bunch of Teams listing in my available commands. I tried each one until one worked. I have several MS365 accounts in my Outlook profile, maybe that is why? Within Teams, I am connected as a guest in multiple tenants plus my personal Teams account in addition to a default Teams account. In Outlook, my profile is connected to 3 MS365 accounts plus an outlook.com account. It does not seem to know who I am or what I want to do. This is certainly a half-baked solution to the "Share to Teams" attempt. It should know the context of what inbox I am in or at least attempt to ask me. If I am in another Inbox and click share to teams, it says it cannot get the content. If I use the standard install, without changing the ribbon bar, it will not work at all. I am wondering if anyone had done any QA on this component?

 

 

 

Thank you very much. Your solution does work, but Microsoft need to fix it. We can not educate every user to play around it.

Has anyone reported to MSFT?

Thanks
Ryan
Hello everyone ! Your suggestion is very correct and everyone who has [the problem with Teams should 1 step directly immediately report feedback to the team Teams with the appropriate attachments that will show - the problem ] It is not good that the users themselves have to fix repeated errors in the operation of the application! Thank you for your suggestions. Good luck!
Worked for me as well. I hope this gets fixed quickly