Not receiving any messages or notifications from MS Teams on Mac OS X (Monterey 12.3.1)

%3CLINGO-SUB%20id%3D%22lingo-sub-3342553%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20receiving%20any%20messages%20or%20notifications%20from%20MS%20Teams%20on%20Mac%20OS%20X%20(Monterey%2012.3.1)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3342553%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1384710%22%20target%3D%22_blank%22%3E%40chrisxhorn%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehave%20you%20checked%20Notifications%20settings%20on%20the%20Mac%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Adin_Calkic_0-1652090615889.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F370165i2853B23A95AEF9B7%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Adin_Calkic_0-1652090615889.png%22%20alt%3D%22Adin_Calkic_0-1652090615889.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20assuming%20that%20you%20checked%2C%20and%20re-enabled%20Notifications%20in%20Microsoft%20Teams%20in%20Settgins%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3342577%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20receiving%20any%20messages%20or%20notifications%20from%20MS%20Teams%20on%20Mac%20OS%20X%20(Monterey%2012.3.1)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3342577%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1370919%22%20target%3D%22_blank%22%3E%40Adin_Calkic%3C%2FA%3E%2C%20yes%20I%20already%20tried%20turning%20the%20notification%20on%20and%20off.%20But%20it's%20normal%20that%20I%20don't%20get%20notifications%2C%20the%20issue%20is%20not%20with%20the%20notifications%2C%20it's%20because%20I%20don't%20actually%20receive%20any%20message%20or%20updates%20on%20threads%20even%20if%20I%20open%20the%20app%2C%20so%20there's%20no%20notification%20to%20be%20shown.%3CBR%20%2F%3E%3CBR%20%2F%3EAs%20soon%20as%20I%20refresh%20the%20web%20app%2C%20or%20re-open%20the%20desktop%20app%2C%20all%20the%20messages%20and%20notifications%20appear%20from%20the%20past%20few%20minutes%2C%20but%20I%20don't%20get%20any%20new%20messages%2Fnotifications%20until%20I%20re-open%2Frefresh%20again.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3342517%22%20slang%3D%22en-US%22%3ENot%20receiving%20any%20messages%20or%20notifications%20from%20MS%20Teams%20on%20Mac%20OS%20X%20(Monterey%2012.3.1)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3342517%22%20slang%3D%22en-US%22%3E%3CP%3EOn%20my%20MacBook%20Air%20M1%20(running%20the%20latest%20OS%20X%20version)%20I%20am%20not%20getting%20any%20messages%20or%20notifications%20at%20all%2C%20and%20not%20only%20on%20the%20desktop%20app%2C%20but%20neither%20on%20the%20web%20app.%20As%20soon%20as%20I%20refresh%20(the%20web%20app)%20or%20quit%20%26amp%3B%20open%20the%20desktop%20app%2C%20the%20messages%20will%20appear%2C%20but%20I%20won't%20be%20getting%20any%20new%20messages%2Fnotifications%20until%20I%20refresh%2Fre-open%20the%20app%20again.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20is%20happening%20only%20on%20my%20MacBook%2C%20in%20the%20meanwhile%20I%20get%20all%20the%20messages%26amp%3Bnotifications%20instantly%20on%20my%20iOS%20device.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20have%20already%20tried%20turning%20notification%20on%20and%20off%2C%20cleared%20out%20the%20cache%20by%20removing%20these%20files%3A%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2FApplication%20Cache%2FCache%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2Fblob_storage%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2FCache%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2Fdatabases%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2FGPUCache%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2FIndexedDB%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2FLocal%20Storage%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ELibrary%2FApplication%3C%2FSPAN%3E%3CSPAN%3E%5C%20%3C%2FSPAN%3E%3CSPAN%3ESupport%2FMicrosoft%2FTeams%2Ftmp%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EBut%20since%20the%20web%20app%20is%20behaving%20the%20same%20way%2C%20I%20don't%20think%20that%20it's%20an%20issue%20with%20the%20desktop%20app%20files.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EWorth%20mentioning%2C%20my%20iOS%20device%20(where%20I%20get%20all%20the%20messages)%20is%20connected%20to%20the%20same%20Wi-Fi%20connection%20as%20the%20MacBook.%20And%20also%20MS%20Teams%20was%20working%20fine%20on%20Friday%20(6th%20of%20May)%2C%20and%20I%20have%20not%20changed%20any%20configuration%2C%20did%20not%20install%20any%20new%20apps%20and%20nor%20did%20I%20update%20anything%20else%20on%20the%20laptop.%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20anyone%20knows%20what%20might%20be%20the%20issue%2C%20I%20would%20appreciate%20it%20a%20lot!%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3342517%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMac%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMessaging%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMS%20Teams%20for%20Mac%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENotifications%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3354482%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20receiving%20any%20messages%20or%20notifications%20from%20MS%20Teams%20on%20Mac%20OS%20X%20(Monterey%2012.3.1)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3354482%22%20slang%3D%22en-US%22%3EHaving%20this%20same%20exact%20issue!%20It%20just%20happened%20recently%20for%20me%20as%20well.%3C%2FLINGO-BODY%3E
New Contributor

On my MacBook Air M1 (running the latest OS X version) I am not getting any messages or notifications at all, and not only on the desktop app, but neither on the web app. As soon as I refresh (the web app) or quit & open the desktop app, the messages will appear, but I won't be getting any new messages/notifications until I refresh/re-open the app again. 

This is happening only on my MacBook, in the meanwhile I get all the messages&notifications instantly on my iOS device.

I have already tried turning notification on and off, cleared out the cache by removing these files:

Library/Application\ Support/Microsoft/Teams/Application Cache/Cache
Library/Application\ Support/Microsoft/Teams/blob_storage
Library/Application\ Support/Microsoft/Teams/Cache
Library/Application\ Support/Microsoft/Teams/databases
Library/Application\ Support/Microsoft/Teams/GPUCache
Library/Application\ Support/Microsoft/Teams/IndexedDB
Library/Application\ Support/Microsoft/Teams/Local Storage
Library/Application\ Support/Microsoft/Teams/tmp
 
But since the web app is behaving the same way, I don't think that it's an issue with the desktop app files.
 
Worth mentioning, my iOS device (where I get all the messages) is connected to the same Wi-Fi connection as the MacBook. And also MS Teams was working fine on Friday (6th of May), and I have not changed any configuration, did not install any new apps and nor did I update anything else on the laptop.

If anyone knows what might be the issue, I would appreciate it a lot!



3 Replies

Hi @chrisxhorn ,

 

have you checked Notifications settings on the Mac?

 

Adin_Calkic_0-1652090615889.png

 

I'm assuming that you checked, and re-enabled Notifications in Microsoft Teams in Settgins?

Hi @Adin_Calkic, yes I already tried turning the notification on and off. But it's normal that I don't get notifications, the issue is not with the notifications, it's because I don't actually receive any message or updates on threads even if I open the app, so there's no notification to be shown.

As soon as I refresh the web app, or re-open the desktop app, all the messages and notifications appear from the past few minutes, but I don't get any new messages/notifications until I re-open/refresh again.
Having this same exact issue! It just happened recently for me as well.