Not receiving any messages or notifications from MS Teams on Mac OS X (Monterey 12.3.1)

New Contributor

On my MacBook Air M1 (running the latest OS X version) I am not getting any messages or notifications at all, and not only on the desktop app, but neither on the web app. As soon as I refresh (the web app) or quit & open the desktop app, the messages will appear, but I won't be getting any new messages/notifications until I refresh/re-open the app again. 

This is happening only on my MacBook, in the meanwhile I get all the messages&notifications instantly on my iOS device.

I have already tried turning notification on and off, cleared out the cache by removing these files:

Library/Application\ Support/Microsoft/Teams/Application Cache/Cache
Library/Application\ Support/Microsoft/Teams/blob_storage
Library/Application\ Support/Microsoft/Teams/Cache
Library/Application\ Support/Microsoft/Teams/databases
Library/Application\ Support/Microsoft/Teams/GPUCache
Library/Application\ Support/Microsoft/Teams/IndexedDB
Library/Application\ Support/Microsoft/Teams/Local Storage
Library/Application\ Support/Microsoft/Teams/tmp
 
But since the web app is behaving the same way, I don't think that it's an issue with the desktop app files.
 
Worth mentioning, my iOS device (where I get all the messages) is connected to the same Wi-Fi connection as the MacBook. And also MS Teams was working fine on Friday (6th of May), and I have not changed any configuration, did not install any new apps and nor did I update anything else on the laptop.

If anyone knows what might be the issue, I would appreciate it a lot!



5 Replies

Hi @chrisxhorn ,

 

have you checked Notifications settings on the Mac?

 

Adin_Calkic_0-1652090615889.png

 

I'm assuming that you checked, and re-enabled Notifications in Microsoft Teams in Settgins?

Hi @Adin_Calkic, yes I already tried turning the notification on and off. But it's normal that I don't get notifications, the issue is not with the notifications, it's because I don't actually receive any message or updates on threads even if I open the app, so there's no notification to be shown.

As soon as I refresh the web app, or re-open the desktop app, all the messages and notifications appear from the past few minutes, but I don't get any new messages/notifications until I re-open/refresh again.
Having this same exact issue! It just happened recently for me as well.

@johma0xff  @Tmank1580 

Hey guys,

 

For me it was fixed automatically, I did not do anything else other than what I specified in the thread. Sadly, MS Teams is behaving weird a lot of times on MacOS, and I still experience some issues from time to time, but they are mostly intermittent.