No audio devices

%3CLINGO-SUB%20id%3D%22lingo-sub-1402802%22%20slang%3D%22en-US%22%3ENo%20audio%20devices%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1402802%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20installed%20Teams%20for%20over%20a%20month%20now%2C%20but%20since%20a%20week%20I%20have%20the%20following%20problem%3A%20'I%20can't%20select%20any%20Audio%20devices%20in%20the%20app'.%20I%20only%20can%20select%20on%20the%20top%20custom%20setup%2C%20but%20for%20the%20speaker%20and%20microphone%20option%2C%20I%20have%20no%20options%20as%20seen%20in%20the%20first%20picture.%20So%20when%20I%20try%20to%20perform%20a%20test%20call%2C%20I%20even%20can't%20do%20that%20(as%20seen%20in%20the%20second%20picture).%20This%20issue%20just%20randomly%20started.%20I%20already%20reinstalled%20my%20teams%20and%20removed%20all%20of%20the%20audio%20devices.%20Does%20anyone%20has%20a%20solution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1402802%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

I have installed Teams for over a month now, but since a week I have the following problem: 'I can't select any Audio devices in the app'. I only can select on the top custom setup, but for the speaker and microphone option, I have no options as seen in the first picture. So when I try to perform a test call, I even can't do that (as seen in the second picture). This issue just randomly started. I already reinstalled my teams and removed all of the audio devices. Does anyone has a solution?

5 Replies

@Axel_ParolI had exactly the same issue, tried removing, manually cleaning out temp files, etc...

 

After every fresh re-install I had the same problem - in devices I just saw "Custom Setup" under audio and I couldn't change it..

 

Today I decided to try again and sure enough, it displayed the same problem.  By pure chance I got distracted and left my PC unattended for around half an hour, and when I came back to it, it had populated the audio settings with my headset. 

 

I don't think I'd ever tried leaving it in the hope it would change things, maybe worth a try?

I'm having the same issue. Very buggy behaviour of late.  Not sure if a Windows 10 problem or Teams, either way, hey MSFT WTF? Audio troubleshooter does nothing but run endlessly.

 

I had the same issue with the online version, I downloaded the desktop app and it works as expected.

@Tyler_B1210 Any solution to this problem? I can't use Teams as I have no devices except the indication of custom setup :(

So I eventually got to the bottom of it on my machine. I have an Elgato 4k60 HDMI capture card and I had the thought to try disabling this device. After this, I was able to select my audio/video devices in Teams without any problem.

Thankfully I use the capture card rarely, so this workaround is good enough for me..