Missing Profile Icon

Copper Contributor

The profile icon on the top right of the headline search bar that donates current status and allows you to adjust settings etc has disappeared. How is it best restored?

14 Replies
I’d try to log out and log back in! Since you normally log out from what’s missing! I do believe you can right click teams in the task bar or on the app at the bottom and choose log out though


Same issue happening to a few of my users, now I resolved the issue by removing Teams and installing it again, but that seem to solve it for 24hr and that icon disappears again.

I'm having the same issue with one of my end users. Uninstalled and re-installed Teams to fix it yesterday, but today it's missing again.

@FBurns2415 I right clicked the MS Teams icon on the taskbar and selected 'Quit'. When I opened MS Teams again, the profile icon was restored. However, looks like it's happening a lot recently. One thing I have noticed is the profile icon goes missing if I close Teams with a chat/meeting that I have not initiated.

It seems that is due to some left over problems that Teams is having after the outage they had last week, they are still working their way through to resolve all the issues.

Short and Best Solution :)

PS: it is there, you just can't see it.  Click where it should be to access the profile menu.  Sign out and back in.  

I can confirm this is the case on my end as well. (as per Dave Isaac's comment about it being there, but you just can't see it). 

Now, in my case, I don't actually have a photo, just my initials. But, I haven't noticed any specific action or activity or timing that triggers it to disappear. I will see if I can identify something.

A simple quit and restart allows the icon to reappear.

I am currently using Dark Mode (in case that makes a difference or is common amongst the problemed users).

Thanks this helps!
Has this problem been solved?

@FBurns2415 Just a heads up to everyone, as of today 7-8-2021 the issue has not been resolved BUT in case you didn't know the icon disappears but it is actually not gone, if you hover over the area you will be able to click on it and get into your settings. I think this maybe resolved in future updates.

I've noticed it today also - it started after an update on July 6th.
My version is



Yep, that worked for me too....

switching on the read receipts under teams app options resolved the issue. Settings --> Privacy -->read receipts @FBurns2415