Mac Desktop application not working with external webcams

New Contributor

I read many posts about this issue going back to 2020 but havent been able to find a fix. I have tried this on two of my macbook airs. One is a 2019 and just yesterday with a brand new out of box 2022 m2. This issue is only with teams mac app as i use zoom, webex, and many other platforms for video conference with no issues. The onboard camera on the laptop works fine but external cameras, which i have tested three different models all cause issues from no picture, to half a green screen to flickering. I have tried all suggested fixes on the other boards but still have the issue and again this works fine on the web version of teams just not the mac app. Any suggestions would be greatly appreciated as I have not been able to find a fix nor has support been able to guide me to a good resolution. I should be able to use the teams app without having to find a workaround.

2 Replies

@John_Smith2165 

Hi, I know this doesn’t help you … I have a M1 Pro Macbook and I use an external camera without any problems with MS Teams Desktop app …

I have only some ideas that I would try if I have this problem:

Did you try to use a Webbrowser for Teams? Does the camera work with the browser-App?

How ist your camera connected? Is it USB-A and you use an adapter? Did you try a different adapter? Are you using a USB-Hub? Did you try to connect directly?

Best regards

Ecki

@Ecki007 Thanks for the ideas. The web browser app has no issues and works fine. Only the desktop app. My camera is connected to one of the two USB-C port via an OEM mac USB to USB C adapter as I haven't found a direct usb c webcam to try and really didn't want to spend any more money to throw at this issue :) . I have also tried using my usb to usbc hub and it also didn't work. Wonder if there is something with the macbook air compared to the pro for the external webcams. It truly is frustrating as i thought as well maybe an adapter issue such as maybe not enough power or something but it works for browser app and for all other browser and desktop app platforms like zoom, google meets, etc with no issues. I also tried removing and reinstalling the desktop app with no luck as well as ensuring that the program was running the latest updates. I also found a thread that had suggested to remove the cache from the desktop app and that didn't work either. :(  It is really boggling my mind as it shouldn't be this hard I would think..