SOLVED

I cannot post images or files in a group chat where everyone else can

New Contributor

I am a member of a group Chat (not a Team or Channel, just a Chat with multiple people). There are 6 people in this Chat, 5 from my company (including me) and one from an external client. My company has external access enabled, and it works fine for everybody else.

 

All of the others in this Chat can post images and files (including the external client), but I can't. There is no error or explanation. The attachment button at the bottom is just missing (along with most of the other buttons), and I get a red circle with a line through it if I try to drag and drop files.

 

I have checked the Teams Admin Center and can't find anything that would block me. I have the exact same Policies assigned as my co-workers who have the ability to post files. Specifically, all of us have "Global (Org-wide default)" for every policy.

 

This exact same thing happened with a previous client as well. Everyone could post files in the group chat, except me. It seems that I, and only I, have a restriction that I cannot send any files to external users.

 

What am I missing? What settings can I check which are applying to my account but not anybody else from my company?

5 Replies
If all settings really are identical and you're the only one having this issue it makes me believe there's something wrong with your licensing, such as SharePoint/OneDrive (the latter where group shared files end up). Try verifying your licensing and also do a manual sign out of your OneDrive and back in again. Still, you're saying you're missing other icons as well and that usually happens when you're trying to share files to an external account, not the guest account. They are different identities in that way having the same email address with the ending "external" and "guest" after the name. You can search in the chat window to see what i mean. Guests can only share files in channel conversations and you cannot share files to guests unless you change the sharing link to "people in this chat" or "specific people" (same thing) because then you're adding a secure link using external sharing instead.

@ChristianJBergstrom 

Thanks for the suggestions. The chat where I cannot share files does have an External participant (not guest). Everyone else in the chat, both External and from my company can post files without issue. I heard somebody say the missing buttons at the bottom of the chat means it's function in Basic mode, which is normal if you are the external participant, but in this case the Chat is located in my organization's Teams.

 

I checked my licensing and it seems correct. I do use Sharepoint and OneDrive, and have permissions set that I can share files externally, even to non-guest accounts. I do this regularly.

 

I should also mention that this problem exists for me in both the desktop app and the web app on any computer (I have tried on 3). HOWEVER, from Teams android app on my phone, I do not have this restriction and I can post files.

 

Using federation (external access) you cannot share files. Not you or the user from the trusted org. You will not even see the attachment icon. The same goes for guest access unless you change the default sharing link. You never share attached files in Teams, they are always links pointing to either SharePoint or OneDrive.

I should mention that I'm not just talking about uploading documents. The most annoying thing is that I cannot post screenshots (or any other images). I believe these are not OneDrive objects, but embedded in the Teams chat.

 

I have heard from others that you simply can't share any files or images in a Chat with an External participant, but the thing is that everyone else from my organization can drop files and images into this Chat, and the External person can as well. And I can actually add files to this Chat from Teams on the Android app. It is only my account when using Desktop or Web Teams which can't upload files.

We are not federated with the organization of the External participant. Their 365 Tenant is not connected to ours in any way, except for this one user being manually invited to this one Chat.

best response confirmed by Bstove5 (New Contributor)
Solution
I found the solution to my own problem. Hopefully it helps others.

I learned my co-workers were all dropping screenshots into the chat from the Windows Snipping Tool. If you take a screenshot with that (Shift+Win+S) it automatically copies the image to your clipboard, and CTRL+V will work to paste it in the chat.
I tested with my preferred screencap app (ShareX) and it does not work to paste. Neither does an image copied from Windows Photos app, or any other app that I tested. It would seem that the Snipping Tool has some exception, and can paste into any Teams chat, even one with an external party.

So, to recap, for Teams Chat that includes and External participant: You can attach files with no problem from the Android app, but not Desktop or Web apps. For Desktop or Web, the only program which will allow you to paste an image is the Windows Snipping Tool.

Hopefully this saves somebody else the weeks of frustration it has caused me.