Cannot Remove "Document Library" tab

Steel Contributor

Hello all,

was just notified of an issue when an Owner of a Team could not Remove a tab from a Team.

These tabs have been in place for a long time.

The tab is the Microsoft "Document Library" type.  We both also tried in web version of Teams and we still do not get an option to "Remove".

Our only choices are Expand, Reload, Copy Link to tab and , About this tab.



If we choose about the image icon is broken graphic.



I even added a new Document Library to a channel in one of our test Teams and now I cannot remove it.


There are no Health or Service Incident notices posted in any of the Administrator Portals.

Any ideas of how to manage these "Document Library" tabs?

8 Replies

We are going to also create Support Ticket with Micrsoft. I know that is obvious but didn't want people to just post those kinds of responses.

I also found this reference about the Document Library being deprecated in the New Teams Desktop Client. (not using this yet).
It also says it is supposed to convert to a SharePoint Doc Library on first use.  Which indicates this may be a related issue to MS deprecating the Document Library  when rolling out New Teams Client.  But we are not using the New Client and I also tried using the New Client and cannot Remove the tabs.

When I click on the tab as if to actually use it, it just gives blank page.

We have since discovered that Teams Desktop is experiencing a similar issue with any links to Document libraries. We have several Home pages of our Teams that contain a webpart of links or Quick Links. If the links reference Document Libraries they will not work as navigation. They are displayed and the Teams Desktop detects they are links because the cursor changes states.
However, Teams Desktop will not navigate or action mouse clicks. Web Teams works fine.
We believe Teams Desktop is somehow blocking the navigation or Mouse click event.
The New Teams Desktop actions the links to Document Libraries as expected.
best response confirmed by Forrest Hoffman (Steel Contributor)
This must have been an unpublished Microsoft services issue. Was notified the situation was resolved and Teams Desktop was back to working the way it is supposed to. I have since verified the operation is nominal.
We have the same problem, but it's not resolved for us. The remove option is completely missing.

Same broken graphic as above, so the issue does still seem to be there.

It's the same on both the old and new Teams desktop client, including the website.

@Anthony Russell 


Have you been able to resolve this issues?

I did. Try the mobile teams app. The option to remove them still works there. I used Teams on iOS specifically.