Cannot add external users

Occasional Contributor



I am having some issues in regards to adding external users to in Teams.

When I try to add an external account, I am met with the "we didn't find any matches" message.


The following i set in AAD( I have a global admin account):


The following is set in Teams admin center:



So if these to settings does still not allow me to add external users, then what will? Not sure where else to look, so if anyone has a suggestion I am all ears :-). 




3 Replies

@miclarsen1 Hi, if you receive a "We didn't find any matches" error while trying to add a guest it usually means your organization doesn't allow guests. 


When did you enable the guest access? It can be quite a delay for the setting to take effect in all services (several hours).


I'm attaching this for reference/guidance, note the 24 hours delay as well.


Hi @bec064,


Thank you for replying.

I agree that is what the message means.

The question is why am I getting this message, when seemingly adding external users should work, since I have set it to be allowed both in AAD and Teams admin center.


The thing is, could there be something else in place I need to consider, that could potentially be the cause of this?

Guess access was enabled on monday this week, so I recon that is not the problem.


Best regards,


Best Response confirmed by ThereseSolimeno (Microsoft)

@miclarsen1 Hello! Well, if you have verified all the settings in the above link it sure sounds a bit odd. Especially since you enabled it several days ago. 


Have you tried using PowerShell to verify and perhaps turn off / turn on again?