Can't log in to my own organisation after inactivity

New Contributor

Hi all,

I set up MS Teams for my own organisatin (Free version). I am the one who set it up and the only one in the organisation. I haven't used it for a few months and when tried to set up calls with clients recently, I found that I can no longer log in. 


It let's me select <ABC> org when logging in, go through the verification process, but then I get the following message: "You don't have access to the <ABC> org in Teams. Select another org, or contact your admin for more details."


I have tried deleting the cache, uninstalling and reinstalling Teams but with no result. I have tried using the web app and desktop app, Chrome and Microsoft Edge.


Any advice?


3 Replies
Hi, as it been months it could be that is has been deleted if you haven't been active/signed in? I know Microsoft introduced automatic license expiration of 3 months for Teams free orgs. missing activity. This because so many people create Teams free orgs. without using them.

So probably you need to set one up again but with a different account. You have access to Azure AD free when using Teams free so to verify you can also try signing in here If no luck, probably not there anymore. Do this with a separate browser profile or InPrivate / Incognito mode.
Thank you for your response. I think it did get deleted, but I wish I got notified about that before it happened. I was working for a client for a few months and had no need to use my Teams account, which doesn't mean I wasn't going to want to go back and use it now that the contract is over! Unfortunate. Thank you for your help Christian.
Np. You should have received an email with license expiration notice.