Can no longer share system audio from a Mac

Brass Contributor

Hi. I used to be able to share my screen and include system audio. I haven't done it in a while. When I tried to share today and I noticed this messaged that asked me to install a driver.


When I clicked Install, I get the following message. 



My OS Version: macOS Big Sur 11.4 and Teams Version: 


Any ideas, please?


14 Replies
If that was working previously then that's odd as the setup should only need to run once - as the screenshot indicates.

Are there any updates available for Teams? I'm on Also check for further Mac OS updates perhaps?

Thanks @PeterRising. Unfortunately, the issue isn't resolved.


I'm on the latest version of macOS and Teams. Perhaps, the difference in our Teams' versions could be Tenant specific? A colleague is also experiencing the thing and we have the same versions. I've completely reinstalled Teams after clearing the cache but the issue still exists. 

Teams updates don't necessarily roll out to each tenant at the same time. So that could account for the version difference.

I have the same issue in Teams on macOS Big Sur (11.4). So seems to be a wider spread issue. Are you running an M1 Mac device by any chance?
I'm running on Intel. What version of Teams are you on. Are you running on the beta update channel or standard?

On the M1 Mac: You have Microsoft Teams Version It was last updated on 28/06/2021.

On the Intel Mac: You have Microsoft Teams Version It was last updated on 06/07/2021.

My initial hypothesis was that it might be due to Teams not being native ARM for M1 devices causing the issue on my main system. But I can confirm that on the Intel Mac it also doesn't work.

Seems to be "support case worthy" :)


Edit: Ran update again on the Intel device, it's now up to the same version as the M1 device. After restarting Teams, the toggle completely broke on the Intel device, eg. I can toggle it, it doesn't prompt for driver installation but it also immediately disables system audio as well....

Oops! seems to be the culprit. I've opened a support case.
Good plan. Please let us know how you get on.
Same issue, same version. Please post back if you get a fix.
Same issue on multiple devices running version Please do let us know how it goes.
best response confirmed by seunayo (Brass Contributor)
The workaround, for now, is...
Manual installation of the MSTeamsAudioDriver package
1. Download the driver package from
2. Install the package and restart Teams client
Please see my update with the workaround.
Top tip, thanks for sharing!



I tried this work around, and while the driver installed and I no longer receive the error message when toggling on the "share system audio", the audio can no longer be heard - i.e., sharing system audio = system audio no longer makes any sound, disabling system audio sharing = system sound comes back on.  

@seunayo can you please explain me how to install the driver?