Unable to access Forms and other apps

New Contributor

I am having trouble accessing Microsoft Forms. I can access my SharePoint, OneDrive, and the Forms page itself, but when I try and access an existing form or create a new one I am redirected to the sign in page (even though I am already signed in). When I sign in, it simply goes back to the sign in page... over and over and over again...

 

I have tried different browsers, used incognito windows, cleared cache/cookies/etc etc restarted my computer.. nothing is working.

 

Desktop apps are working fine and are up to date (not that that should matter).

 

I tried my other apps and found the following other problems:

Trying to access a document in Delve (I can open the app page itself, just like Forms), the Calendar app, People app, Outlook online (although desktop Outlook is working fine) and the Bookings app leads to a redirect error after about 30 seconds of redirecting.

 

Trying to access a SharePoint team site through outlook (through the email that you get when you are added to a Team site) also leads to a redirect error after about 30 seconds of redirecting (see image).

 

The account is a 365 Business Standard account.

I have not had this problem ever until this morning. other apps online such as Word, Excel etc. are working fine.

5 Replies

Hi @IPerry , Did you manage to resolve this issue? I have the exact same problem. The moment I try to open an existing forms or create a new form, I'm redirected to the login page. Once I type my email ID, it gets into a loop and redirects me to the login page again!? I tried different browsers in the same PC, still the same problem.

 

With the same Microsoft account, I'm able to access my forms in the newer Surface laptops! So, I'm wondering if any plugin needs to be installed or are there any known issues with Microsoft Edge?

Any help to resolve this issue is much appreciated.

 

Hi, @KVBloggs 

 

After searching for what felt like forever, I saw that some people had the same problem if they had too many admin privileges - when I looked at mine, I saw that every possible choice was checked off (my husband - since we're only two people in the company). I read that can lead to too many redirects etc.

 

So I removed all privileges except the global one - which gives you all privileges by default so the other ones don't need to be checked off. Restarted everything and no problems since. 

Hopefully that will work for you as well. Good luck!

Wow! That worked like a charm! Thanks a lot @IPerry 

 

I was spending hours together trying to resolve this issue.

Your suggestion worked well :smile:

 

 

Glad it worked - I too was absolutely stumped and it wasn't easy to find the solution :)
It did work for me, thanks a lot