Incomplete or empty forms responses (Web App)

Copper Contributor



I created a dozen of forms using only the web app.

I used theses forms everyday for the last 3 weeks and it worked great, with a flow getting the responses into an Excel worksheet.


But for the last three days, i'm getting trouble with the forms responses. Some of them are empty (sometime it's just a section, or it can be the whole response).

I have done videocalls with my users to see if they were filling the forms correctly, and it was ok.

I have changed the questions answers to "Mandatory", but when the user fills it, i still get empty responses.


Because I created them in the web application, and not Excel, I don't have the "Sync responses" button.


Form exemple:


Empty answer i got after the user completed it:


The Excel available in the WebApp shows a new entry, with the timestamp, and the user, but zero answers.  


Does anyone have ever met this problem before?

And why did it worked well for three weeks, and went gradualy bananas? (it started with one form getting incomplete responses, and now 7 forms out of 15 are in this situation).


More informations:

I have tried to delete all the responses i got so far in the web app (i don't need them here, because i flow them to an Excel), but it didn't worked.

Each form is sent to a unique user, every day. It happened somedays that a user wrote wrong answers, so I went into webapp and my Excel, deleted it, and asked the user to fill another form.


Thank you for your help,



11 Replies
Also following, I'm also having the same problem!

@SamiMarzouki Sorry for the inconvenience, we had a bug caused this, this was resolved around 12:30 PM PST, but the previously lost response likert data cannot be recovered. 

@Yao Ke I can confirm. It's working flawlessly today :)



@Yao Ke - I am also experiencing this issue, though it looks like the bug was resolved back in April of 2020. Is something else going wrong? The form worked for me a week ago, but now when people submit answers the responses come back as completely blank. 

@hannahmarollo Thanks for reporting the issue. For the missing response, do you mean the response data missing in the Excel file or in the Forms web under the "Responses" tab?

Hi @Jessie Chen - Thanks for your response!


The responses show in the form (and if you export to excel), but they don't show in the SharePoint List that I created that populates the responses. It was working last week, but on Friday it stopped populating the responses at all. 


Here is how the flow looks now. 





@hannahmarollo do NOT use the Forms template to create your flow in Power Automate. It puts in that apply to each which is unnecessary, incorrect and causes the sort of problems you have experienced. I don't know why Microsoft haven't corrected it. Build your flow from new putting the get response details action immediately after the when a new response is submitted trigger.











Los Gallardos
Microsoft Power Automate Community Super User

Hi @RobElliott - 


Thanks for your response. I followed you steps, but now I am getting an error. 


Here is the flow: 




@hannahmarollo I can see nothing wrong with your flow. What is the error message when you click on the date/time of the failed flow?


Los Gallardos
Microsoft Power Automate Community Super User


@RobElliott Here is the message: 



@hannahmarollo it looks like your column type in SharePoint is incorrect; you appear to have set the column type as a number but the response in the form is text. You either need to change the column type in the list to single or multiple lines of text or change the restriction in the form for that question to be number.


Los Gallardos
Microsoft Power Automate Community Super User