Failed to upload your file MS Forms

Copper Contributor



one hour ago i was able to upload files in my form, now i receive the following message: 

failed upload.JPG






Tried different types of files in different browsers, won't help.


43 Replies
I was getting "...not enough storage space available" error when trying to upload. The upload folder was there in OneDrive, but I think it didn't have the right permissions (long story). Just removing and re-adding the file upload question recreated the folder and allowed uploads.

Also, the name of the folder seems to always be "Question", as that's what's in as default before you can set your own question text.


In my situation, a previously deleted user that was recreate was the only one unable to upload files.  The error message was:  Access denied. You do not have permission to perform this action or access this resource

To resolve it, microsoft sent me the solution and it worked perfectly to resolve the issue:


  • Sign into with the account of the user that shared the Microsoft form. 
  • Click on OneDrive from the App launcher. 
  • Select Return to classic OneDrive. 
  • Click on Settings >> Select Show Ribbon >> Click on Library 
  • From Library ribbon, Select Library settings. 
  • Select permissions for this document library. 
  • Modify the URL by adding /_layouts/15/people.aspx/membershipGroupId=0 
  • Select the user and Click on Actions >> Select Delete user from site collection.
  •  Then, the respondent / user will be able to upload files on the Microsoft form.


Have a great day you all!!

Your approach worked for me as well. Also, to avoid rebuilding the form you can delete and re-add the "file upload" portion of the form and save the change. This will create a new folder in OneDrive and will resolve the issue and save new responses in that newly created folder. With this approach you can avoid having to send a new form link to the respondents.@jeet21 

Thanks! I had the same issue trying to set up a form for a customer hosting a sustainability award across multiple companies (different domains, not all on M365 tenants).

I was able to fix the issue as long as I was logged into my account on their tenant, by clearing the form cache (all responses) and starting over with a clear form, using the "only people within the org XYZ can respond". However, when switching back to "Anyone can respond" and sending an invitation to complete the form to my own domain account (which is already a Guest in my customer's Entra ID), I got the same error again. 

Is there a known issue with forms that (for some reason) won't allow file iploads for guest accounts, even Guests that have accounts in an organisations Entra ID?

Any and all ideas would be appreciated!