O365 MFA not sending text to mobile phone

Occasional Contributor
Hi Tech friends,
Our company has several O365 Tenants which we manage and we have recently been updating them to ensure our verification details are correct.
In many instances this sees us go to the MFA setup page in order to add our two Mobile phone numbers and Mobile Verification App as options on the Tenant admin accounts.
Today this isn't working (Tues 7th Jan 2020 @ 12:30 UTC).
When I select the Mobile phone and enter the number (using the United Kingdom dial code) on Step 1 this appears to be accepted and then goes to the Step 2 page. At this point I get the usual circle of dots and then the page does NOT show a box to put the code into as I'd usually expect...
Instead it says:
Step 2: We've sent a text message to your phone on +44 07xxxxxxx
Please check the phone number that you specified or change your preferred option.
Correlation ID: 1f4c2119-7ed9-48b1-aa2c-46df78a3bdxx
Session ID: 300301ef-a9eb-4683-bb3b-fb3c11bccdxx
Then a Retry and a Cancel button.
No text is received on our phone.
This is true of the two different Tenants we manage that I have tried today.
I have checked the phone receives Texts perfectly (at least from another UK mobile phone).
Does Microsoft have an issue with this service currently?
Any advice greatly received.
10 Replies

@AndyPalmerCTC - without stating the obvious, +44 as the UK dial code replaces the 0 in 07 - looks like there could be too many characters for it to read it as a number as in theory its reading +4407.... 

Just a thought, but let me know how you get on.



Yes I agree however this is what I've been using for some time now, the system seems to accept the first 0 stripping it if required.

Incidentally I have tried today with and without the initial 0 and the effect is the same so I don't believe this is the issue.


As an update to this...

I was able to access one of our Tenants and setup the Password Recovery option email for a standard account. However, when doing this for the logged in Admin account this required both email and phone options to be configured (rightly) - The email option works fine, the phone option neither texts or rings the phone number I put in (tried three numbers including a land-line).

Incidentally we have received a text from Microsoft for an authentication code. This was received some 2 hours after I last tried to do this and we only got one code (having tried at least 4 times).

I'm suspecting MS have an issue with automated text / calls in the UK...
Anyone know who I should contact to get someone to look into this?

best response confirmed by AndyPalmerCTC (Occasional Contributor)

Mysteriously this morning it is now all working again as before (as of 9am UK time).

I can only suggest a MS glitch yesterday which is now resolved.

Thanks for all and any assistance from those on this thread and any others who noticed and were in a position to get it fixed. :)



@AndyPalmerCTC the same issue here again - Feb 5th 2020:

Users enrolled for Multi Factor Authentication (MFA) and used it last night to access Office 365 from a personal computer and received the text on +1 XXX SSS RREE and it worked successfully.


Today they are attempting to access the Office 365 portal this afternoon on the same computer but not receiving the MFA code on the mobile phone, tried twice and still no text.


@Ali Fadavinia 


Hi Ali,

Just tested and seems to work okay from the UK right now (it's 09:30 GMT here).


@AndyPalmerCTC Thanks for the update,


Here, it was out for few hours and then all delayed messages came through on all messages.


I remember similar thing happened last year also, but Microsoft did not announce anything in the Health view dashboard in the admin portal.

I have been trying now for 10 consecutive days to get into my work email using the text verification and the messages are not being sent. MAY 2021. I have no other option set up, is there any way to circumnavigate the text or add another option? Everything returns to the same mobile text verification option .


You don't say where in the world you are, but I only mention as MS have different service components around the globe and a fault in the UK is unlikely to affect elsewhere...

I'd try using an unauthenticated browser (maybe Incognito mode) and go to as this goes direct to the setup portal for your MFA. I'm assuming that might let you log in okay and allow you to change your MFA details.

If you have setup more than one method when you first configured MFA then you should be able to select alternatives on the web module that requests a text response (i.e. a second mobile number or an email to alternative ISP etc.).

If you didn't set up a second MFA Auth method, why not?

Assuming you have only setup one MFA Auth (SMS) then in the event you made a typo in the number then you'll never get the text... You may need to contact MS Support for that as you may have no way of getting in... get them to clear your MFA, then you can set it up again (two of them!).


Thanks Andy! I'm in the UK and yes, tried all the options you've mentioned, everything returns to the verification texts, I'm waiting for MS support to get back to me. Helpful to know I'm not being stupid though,