Missing "my templates" option on a shared mailbox for 2 people on 2 different mail accounts

New Contributor

shared mailbox, owa, office365, my templates,

Application : Office 365 web (outlook)

OS: Win 10 64bit


We currently have 2 users who are unable to see the templates button\option on a shared mailbox. Other users can see this fine without any problems. We have made this as part of our group policy. 


The 2 people in question can see my templates in their own mailbox, and when you add the shared mailbox under folders they can see the personal templates. But when you you choose the option to open another mailbox, type in the shared mailbox name\mail address and then click new message no template icon shows. 


Both are on different shared mailboxes and this did work up until recent. Nothing has been installed only updates for windows and office etc as it is for all in the company.   


When we open the shared mailbox on the users PC, and go to settings, view all outlook settings, email, customise actions and then scroll to the bottom, the option to tick my templates is missing. So unable to tick it to add it. Also noticed in this menu when you tick the get addins, this doesn't show up on the new e-mail. But if I take of an option this does disappear. 


Tried this in both chrome and IE11 and the same issue shows, also tried this on a different PC but still the same issue. 


Under exchange and organisation the 'my templates' is selected and mandatory and enabled for everyone. As seen when you look at the addins section under the option for my account and settings. 


Cache has also been cleared from both browsers. 


Has anyone any ideas please as this is driving me mad.  

2 Replies

The add-in is one of the default ones, so should be available for all mailboxes, shared ones included. Is it shown when you hit the … menu? You should still check this via the Get-App cmdlet:


Get-App -Mailbox shared@domain.com


As for customizing the actions, once the add-in is enabled it should be visible under the Options menu. I've confirmed this with one of my shared mailboxes, but because it wasn't ticked by default I had to manually select it from the … menu first.

Hi, @Vasil Michev 


Thank you for your reply.


The addin in exchange is set to mandatory on everyone. So all the users have this and can see the templates. This setting stops users from taking the tick off in their own mailbox. So we know it is enabled for the entire organisation. All other users who use the 2 shared mailboxs can see the template button on the new message. So we know it is still working. 


It has worked in the past for the 2 users, which is what I can't understand, and I have removed the addin from account and put it back on to see if this fixes the issue, but still the same.