Error code: CAA50021 when trying to login to office 365

Copper Contributor

Hello experts,

One of my end users is unable to log in to Office 365 on her laptop, although she can log in on her desktop, via the web, and in the admin account of the laptop. When attempting to log in on the laptop, it gets stuck at "Hold on While we register this device with your company and apply policy." Sometimes, she can log in to one of the Office apps, but when attempting to open another app, it either gets stuck loading or prompts for login again with the CAA50021 code.

2.PNGCapture.PNG

We have tried the following steps:

  • Removed all credentials from credential manager.
  • Checked Azure AD to ensure nothing was blocking the client from signing in.
  • Cleared the Office 365 cache.
  • Run Windows update.
  • Ended all user sessions from the admin center.
  • Re-downloaded and re-installed the app.
  • Deleted data folders.
  • Confirmed that the device is registered with Active Directory.
  • Restarted the computer.

 

Any advice on how to fix this issue would be greatly appreciated.

 

8 Replies

This happens with our users and none of the suggested fixes work. @Nawidahmad 

Happens to our users as well, even that weird SaRA tool basically does nothing and just says "success" at the end without anything working.

Is reinstalling Windows the only way to solve this?

@Nawidahmad 

Did you ever get an explanation and eventual solution to this? We're currently experiencing this in my org and the work-around at the moment is to run cmd as admin and execute the "dsregcmd /leave" command, then restart the device and join again (dsregcmd /join). This clearly is convenient in a production environment, was wondering if anyone has some pointers what could be wrong.

@Nawidahmad 

I tried everything. This worked 1st time for me:

Remove Office credentials

  1. From Start, type credential manager, and then select Credential Manager from the search results.
  2. Select Windows credentials.
  3. If there are any credentials for MicrosoftOffice16, select the arrow next to them and then select Remove.
  4. Close Credential Manager.
  5. From Start, select Settings (the gear icon) > Accounts > Access work or school.
  6. If the account you use to sign in to office.com is listed there, but it isn’t the account you use to sign in to Windows, select it, and then select Disconnect.
  7. Restart the device and try to activate Microsoft 365 again.

This is the link:
Microsoft 365 Apps activation error 0xCAA50021 

@Nawidahmad 

 

May I know the laptop is AD or AAD join?

Its not joined to the domain, it is a personal device.
Sometimes removing all the MS credentials helps but I found that removing the device from AAD/Entra and re-installing Office on the device works. We have not set up Intune so I'm not sure how those devices are being managed or mismanaged by AAD/Entra when our users set up Office 365 on their personal devices. Removing the device from Entra and reinstalling Office and forcing a logout of the user seems to work now but its almost random if it works or not. Maybe it is a lag or delay when performing those tasks and we are just working too fast for the cloud to catch up. After doing these things and waiting 24 hours it seems to resolve itself so I would suggest removing the device from Entra, removing Office from the device, forcing a logout and wait until the next day to install Office and log in again.

Thanks for all the suggestions and help!
Thanks to everyone for their responses. Unfortunately, we ended up replacing the computer.

@Nawidahmad  I am in the exact same situation, a  user just won't login into onedrive , I tried eveything , re-installed 365 apps, cleared credentials. One drive just takes forever to login and then gives the Error code: CAA50021