SOLVED

Installing MicrosoftEdgeEnterpriseX64.msi - Error 1722

%3CLINGO-SUB%20id%3D%22lingo-sub-1230812%22%20slang%3D%22en-US%22%3EInstalling%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1230812%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20installing%20MicrosoftEdgeBetaEnterpriseX64.msi%20(current%20Version%2080.0.361.48)%20I%20get%20following%20MSI%20Error%201722%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EProduct%3A%20Microsoft%20Edge%20for%20Business-%20Error%201722.%20There%20is%20a%20problem%20with%20this%20Windows%20Installer%20package.%20A%20program%20run%20as%20part%20of%20the%20setup%20did%20not%20finish%20as%20expected.%20Contact%20your%20support%20personnel%20or%20package%20vendor.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAt%20first%2C%20I%20thought%20it%20was%20being%20caused%20by%20the%20update-restriction%20being%20applied%20via%20GPO%20(ADMX)%2C%20but%20even%20without%20this%20GPO%20settings%20applied%20or%20by%20reverting%20the%20corresponding%20setting%20in%20the%20registry%2C%20the%20installation%20fails%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20occurs%20on%2057%20from%20240%20workplaces%20(Windows%2010%20build%201709)%2C%20but%20also%20on%20one%20Windows%2010%20build%201903.%20Remaining%201709%20builds%20successfully%20installed%20the%20application.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22SanderVR_0-1584369861389.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F177207i9394765C4BE890DC%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22SanderVR_0-1584369861389.png%22%20alt%3D%22SanderVR_0-1584369861389.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ELogfile%3A%20MSIc3130.LOG%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EError%201722.%20There%20is%20a%20problem%20with%20this%20Windows%20Installer%20package.%20A%20program%20run%20as%20part%20of%20the%20setup%20did%20not%20finish%20as%20expected.%20Contact%20your%20support%20personnel%20or%20package%20vendor.%26nbsp%3B%20Action%20DoInstall%2C%20location%3A%20C%3A%5CWINDOWS%5CInstaller%5CMSI4045.tmp%2C%20command%3A%20%2Fsilent%20%2Finstall%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Bappname%3DMicrosoft%20Edge%26amp%3BneedsAdmin%3DTrue%26amp%3Busagestats%3D0%26amp%3Bap%3Dstable-arch_x64%22%20%2Finstallsource%20enterprisemsi%20%2Fappargs%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Binstallerdata%3D%257B%2522distribution%2522%253A%257B%2522msi%2522%253Atrue%252C%2522system_level%2522%253Atrue%252C%2522verbose_logging%2522%253Atrue%252C%2522msi_product_id%2522%253A%2522DCF62978-E764-38B6-8D70-FD4BFF0EDEE5%2522%252C%2522allow_downgrade%2522%253Afalse%257D%257D%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOther%20issue%3A%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Finstalling-microsoftedgebetaenterprisex64-msi-error-1722-when%2Fm-p%2F843654%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fenterprise%2Finstalling-microsoftedgebetaenterprisex64-msi-error-1722-when%2Fm-p%2F843654%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20someone%20help%20us%20out%20finding%20a%20solution%20to%20the%20install%20failure%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1231952%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1231952%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F583219%22%20target%3D%22_blank%22%3E%40SanderVR%3C%2FA%3E%26nbsp%3BYour%20solution%20in%20finding%20lies%20in%20finding%20the%20difference%20between%20the%20systems%20that%20have%20the%20deviation%20(57)%20and%20those%20that%20have%20not%20(240).%3C%2FP%3E%3CP%3E1722%20usually%20means%20that%20a%20object%20or%20action%20in%20the%20msi%20could%20not%20be%20completed.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20suggest%20looking%20at%20software%20that%20is%20on%20the%20IS%20systems%20versus%20the%20IS%20NOT%20systems.%3C%2FP%3E%3CP%3E*%20Is%20there%20already%20a%20Edge%20Chromium%20present%20on%20those%20systems%3F%3C%2FP%3E%3CP%3E*%20Maybe%20Adobe%20Flash%20is%20installed%20on%20the%2054%3F%20Which%20cannot%20be%20removed%20without%20manual%20intervention%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ereg%2C%20Henno%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1232302%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1232302%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20exact%20same%20problem%20here%2C%20but%20using%20Edge%2080.0.361.66.%3C%2FP%3E%3CP%3ENo%20Adobe%20Flash%2C%20and%20no%20Edge%20Dev%2FBeta%2C%20just%20the%20default%20classic%20Edge%20distributed%20with%20Win10%201903.%3C%2FP%3E%3CP%3EI'm%20not%20sure%20what%20other%20installed%20software%20might%20block%20the%20Edge%20installer%2C%20any%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20regards%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1232393%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1232393%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F584156%22%20target%3D%22_blank%22%3E%40tjoanp%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20had%20this%20error%20with%20machines%20not%20enough%20space%20on%20c%3A%5C.%20so%20this%20error%20is%20just%20an%20something%20went%20wrong%20flag%20and%20doesnt%20say%20anything%20about%20an%20possible%20resason%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1246145%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1246145%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F400875%22%20target%3D%22_blank%22%3E%40Henno_Keers%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20reply.%20It%20is%20a%20good%20starting%20point%2C%20but%20we%20can%20already%20check%20these%20from%20the%20list%3A%3C%2FP%3E%3CP%3E-%20No%20Adobe%20Flash%3C%2FP%3E%3CP%3E-%20No%20previous%20Edge%20Chromium%20installations%20(as%20this%20is%20an%20initial%20deployment)%3C%2FP%3E%3CP%3E-%20No%20lack%20of%20available%20space%20on%20C%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFurther%20more%2C%20there%20shouldn't%20be%20much%20difference%20between%20these%20systems.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EApparently%20I%20am%20not%20the%20only%20one%20facing%20this%20issue%2C%20according%20to%20the%20reaction%20of%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F584156%22%20target%3D%22_blank%22%3E%40tjoanp%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20be%20sure%20it%20is%20not%20caused%20by%20any%20system%20files%20being%20corrupt%2C%20I%20will%20run%20a%20DISM%20%2F%20SFC%20scan%20on%20one%20of%20the%20affected%20systems%20and%20try%20again.%20Will%20keep%20you%20guys%20posted...%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1246276%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1246276%22%20slang%3D%22en-US%22%3EI%20ran%20%22DISM%20%2Fonline%20%2Fcleanup-image%20%2Frestorehealth%22%20with%20success%20and%20a%20%22SFC%20%2Fscannow%22%20finished%20with%20a%20reboot.%20The%20SFC%20scan%20found%20errors%20and%20repaired%20them%2C%20but%20unfortunately%20this%20did%20not%20solve%20the%20install%20issue%20for%20me.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1246403%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1246403%22%20slang%3D%22en-US%22%3E%3CP%3EToday%20I%20retried%20the%20MSI%20install%20on%20a%20computer%20where%20it%20failed%20last%20week%2C%20and%20this%20time%20the%20installation%20went%20through%20without%20any%20hazzle.%20The%20only%20thing%20I%20*know*%20had%20changed%20was%20that%20the%202020-03%20windows%20patches%20had%20been%20installed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1255944%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1255944%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F584156%22%20target%3D%22_blank%22%3E%40tjoanp%3C%2FA%3E%26nbsp%3B%20Thanks%20for%20your%20reply!%20I%20sure%20owe%20you%20a%20beer%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Fhtml%2Fimages%2Femoticons%2Fhappyface_40x40.gif%22%20alt%3D%22%3Ahappyface%3A%22%20title%3D%22%3Ahappyface%3A%22%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20installing%26nbsp%3B%3CSTRONG%3Ekb4541330%3C%2FSTRONG%3E%20(%3CSTRONG%3E2020-03%3C%2FSTRONG%3E%26nbsp%3BCumulative%20update%20for%20Windows%2010%201709%20x64)%20-%20%3CFONT%20color%3D%22%23FF0000%22%3Ewhich%20is%20about%201050MB%20in%20size!%3C%2FFONT%3E%20-%20The%20same%20Edge%20Chromium%20build%20installed%20without%20any%20issues..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20these%202020-03%20updates%20are%20now%20being%20deployed%20to%20the%20farm%20anyway%2C%20I%20%3CSTRIKE%3Eexpect%3C%2FSTRIKE%3E%26nbsp%3Bhope%20the%20issue%20to%20resolve%20itself!%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Fhtml%2Fimages%2Femoticons%2Fcool_40x40.gif%22%20alt%3D%22%3Acool%3A%22%20title%3D%22%3Acool%3A%22%20%2F%3E%20Let's%20see%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20all%20for%20your%20responses.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGreetings%3C%2FP%3E%3CP%3ESander%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1311080%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1311080%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F583219%22%20target%3D%22_blank%22%3E%40SanderVR%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20the%20same%20issue%20in%20our%20enterprise.%20Ever%20since%20version%2080.0.361.109%2C%20clients%20that%20previously%20had%20the%20Edge%20Beta%20enterprise%20installed%20will%20fail%20to%20install%20the%20enterprise%20MSI%20anything%20from%2080.0.361.109%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20last%20successful%20deployment%20that%20was%20largely%20successful%20to%20devices%20was%2080.0.361.69.%20Ever%20since%20version%20.109%2C%20the%20MSI%20fails%20on%20the%20same%20step%20as%20yours.%20(See%20at%20the%20end%20of%20this%20post%20for%20the%20log).%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20additional%20troubleshooting%20steps%20I%20took%20%3CEM%3E%3CU%3E%3CSTRONG%3Ethat%20didn't%20work%3C%2FSTRONG%3E%3C%2FU%3E%3C%2FEM%3E%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EManual%20uninstalling%20and%20gutting%20out%20Edge%20and%20EdgeUpdate%20files%2C%20registry%20entries%2C%20and%20services%20(sc%20delete%20servicename)%20didn't%20help.%3C%2FLI%3E%3CLI%3EInstalling%20the%20enterprise%20MSI%20of%20version%26nbsp%3B%3CSTRONG%3E80.0.361.69%26nbsp%3B%3C%2FSTRONG%3Efails%20as%20well%20now%2C%20even%20after%20everything%20was%20manually%20removed%3C%2FLI%3E%3CLI%3EInstalling%20the%20newer%20MSIs%20also%20fail%2C%20same%20MSI%20errors%20as%20below.%3C%2FLI%3E%3CLI%3EDisable%20group%20policy%20that%20blocks%20automatic%20updates%20from%20EdgeUpdate%20(and%20also%20deleted%20the%20registry%20items%20for%20the%20respective%20policies%20to%20EdgeUpdate)%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20the%20only%20thing%20that%20has%20worked%20for%20me%20so%20far%3A%3C%2FP%3E%3CUL%3E%3CLI%3EInstall%20the%20latest%20Edge%20Beta%20Enterprise%20MSI%3C%2FLI%3E%3CLI%3ETake%20the%20EdgeUpdate%20command%20that%20is%20from%20the%20MSI%20log%20that%20failed%2C%20and%20run%20the%20command%20manually%20to%20install%20Edge%2081.0.416.53%20(yes%20that%20entire%20block%20is%20one%20command...%20and%20running%20it%20manually%20works%20where%20the%20MSI%20fails%20to%20work).%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3EC%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdgeUpdate%5CMicrosoftEdgeUpdate.exe%20%2Fsilent%20%2Finstall%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Bappname%3DMicrosoft%20Edge%26amp%3BneedsAdmin%3DTrue%26amp%3Busagestats%3D0%26amp%3Bap%3Dstable-arch_x64%22%20%2Finstallsource%20enterprisemsi%20%2Fappargs%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Binstallerdata%3D%257B%2522distribution%2522%253A%257B%2522msi%2522%253Atrue%252C%2522system_level%2522%253Atrue%252C%2522verbose_logging%2522%253Atrue%252C%2522msi_product_id%2522%253A%252249DCD999-3A4A-30D9-8B5B-F1312CEFAB12%2522%252C%2522allow_downgrade%2522%253Afalse%252C%2522do_not_create_desktop_shortcut%2522%253Afalse%257D%257D%22%20%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20the%20snippet%20from%20the%20MSI%20log%20that%20are%20failing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3ECustomAction%20DoInstall%20returned%20actual%20error%20code%20-2147219674%20(note%20this%20may%20not%20be%20100%25%20accurate%20if%20translation%20happened%20inside%20sandbox)%3CBR%20%2F%3EMSI%20(s)%20(A8%3AD8)%20%5B08%3A58%3A53%3A562%5D%3A%20Note%3A%201%3A%201722%202%3A%20DoInstall%203%3A%20C%3A%5CWINDOWS%5CInstaller%5CMSI502B.tmp%204%3A%20%2Fsilent%20%2Finstall%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Bappname%3DMicrosoft%20Edge%26amp%3BneedsAdmin%3DTrue%26amp%3Busagestats%3D0%26amp%3Bap%3Dstable-arch_x64%22%20%2Finstallsource%20enterprisemsi%20%2Fappargs%20%22appguid%3D%7B56EB18F8-B008-4CBD-B6D2-8C97FE7E9062%7D%26amp%3Binstallerdata%3D%257B%2522distribution%2522%253A%257B%2522msi%2522%253Atrue%252C%2522system_level%2522%253Atrue%252C%2522verbose_logging%2522%253Atrue%252C%2522msi_product_id%2522%253A%252249DCD999-3A4A-30D9-8B5B-F1312CEFAB12%2522%252C%2522allow_downgrade%2522%253Afalse%252C%2522do_not_create_desktop_shortcut%2522%253Afalse%257D%257D%22%26nbsp%3B%3CBR%20%2F%3EMSI%20(s)%20(A8%3AD8)%20%5B08%3A58%3A53%3A562%5D%3A%20Note%3A%201%3A%202205%202%3A%20%26nbsp%3B3%3A%20Error%26nbsp%3B%3CBR%20%2F%3EMSI%20(s)%20(A8%3AD8)%20%5B08%3A58%3A53%3A562%5D%3A%20Note%3A%201%3A%202228%202%3A%20%26nbsp%3B3%3A%20Error%204%3A%20SELECT%20%60Message%60%20FROM%20%60Error%60%20WHERE%20%60Error%60%20%3D%201722%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1321060%22%20slang%3D%22de-DE%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1321060%22%20slang%3D%22de-DE%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365660%22%20target%3D%22_blank%22%3E%40Senturion33%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHey%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehad%20the%20same%20issue%20with%20the%20newest%20msi%20version.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJust%20found%20out%20there%20is%20a%20new%20%3CSPAN%3Eparameter%3C%2FSPAN%3E%20added%20for%20the%20msi%20Installer%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Foofhours.com%2F2020%2F04%2F16%2Fdeploying-edge-without-a-desktop-shortcut-the-easier-but-not-easiest-way%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3Ehttps%3A%2F%2Foofhours.com%2F2020%2F04%2F16%2Fdeploying-edge-without-a-desktop-shortcut-the-easier-but-not-easiest-way%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdded%20the%20%3CSPAN%3Eparameter%3C%2FSPAN%3E%20%22DONOTCREATEDESKTOPSHORTCUT%3Dtrue%22%20to%20my%20PSADT%20Script%20and%20it%20worked.%3C%2FP%3E%3CP%3EWorks%20with%20%22false%22%20as%20well!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMaybe%20it%20will%20help%20you%20too%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1322801%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1322801%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365660%22%20target%3D%22_blank%22%3E%40Senturion33%3C%2FA%3E%2C%20if%20you're%20still%20facing%20this%20issue%2C%20could%20you%20send%20MSI%20command%20you%20ran%2C%20and%20the%20following%20EdgeUpdate%20log%20from%20a%20machine%20where%20the%20Edge%20MSI%20failed%3F%26nbsp%3B%25ALLUSERSPROFILE%25%5CMicrosoft%5CEdgeUpdate%5CLog%5CMicrosoftEdgeUpdate.log%3C%2FP%3E%0A%3CP%3EFor%20Edge%20Stable%2C%20the%20latest%20Windows%20updates%20listed%20in%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fmicrosoft-edge-sysupdate-windows-updates%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ethis%20link%3C%2FA%3E%26nbsp%3Bare%20required%20for%20it%20to%20install%2C%20so%20it's%20possible%20you%20were%20hitting%20that%20error%3B%20Edge%20Beta%20does%20not%20have%20this%20requirement.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1355353%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1355353%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F549161%22%20target%3D%22_blank%22%3E%40michli%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%20I%20will%20check%20for%20that%20log%20on%20Monday%20from%20a%20problem%20computer.%20As%20a%20workaround%2C%20I%20enabled%20automatic%20updates%20for%20Edge%20so%20that%20clients%20could%20at%20least%20get%20updated.%20I'll%20see%20how%20the%20deployment%20looks%20with%20the%20current%20release%20of%20Edge%20MSI.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20command%20I%20am%20using%20to%20install%20Edge%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3Emsiexec%20%2Fi%20MicrosoftEdgeEnterprise64.msi%20%2Fqn%20%2Fnorestart%20%2Flog%20%25temp%25%5Cupdate.log%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1380748%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1380748%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20that%20once%20I%20changed%20group%20policy%20settings%20from%20disable%20all%20automatic%20and%20manual%20updates%20and%20instead%20changed%20to%20allow%20manual%20updates%20only%20(by%20going%20to%20Help%20-%26gt%3B%20About)%2C%20the%20MSI%20installs%20properly%20with%20100%25%20success%20rate%20across%20all%20client%20systems.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1380996%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%2081.0.416.53%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1380996%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365660%22%20target%3D%22_blank%22%3E%40Senturion33%3C%2FA%3E%26nbsp%3Bthanks%20for%20following%20up%2C%20yes%20setting%20it%20to%20allow%20manual%20updates%20will%20allow%20you%20to%20install%20newer%20MSIs.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1402173%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20MicrosoftEdgeEnterpriseX64.msi%20-%20Error%201722%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1402173%22%20slang%3D%22en-US%22%3E%3CP%3EClick%20Start%20%26gt%3B%20Run.%20Type%20%E2%80%9CServices.msc%E2%80%9D%20without%20quotes%20and%20press%20Enter.Find%20Windows%20Installer%20and%20double%20click%20on%20it.Set%20the%20startup%20type%20of%20windows%20installer%20to%20manual.Click%20Start%20to%20Start%20Services%20and%20click%20OK.%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F583219%22%20target%3D%22_blank%22%3E%40SanderVR%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

When installing MicrosoftEdgeBetaEnterpriseX64.msi (current Version 80.0.361.48) I get following MSI Error 1722:

 

Product: Microsoft Edge for Business- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

 

At first, I thought it was being caused by the update-restriction being applied via GPO (ADMX), but even without this GPO settings applied or by reverting the corresponding setting in the registry, the installation fails as well.

 

The issue occurs on 57 from 240 workplaces (Windows 10 build 1709), but also on one Windows 10 build 1903. Remaining 1709 builds successfully installed the application.

 

SanderVR_0-1584369861389.png

 

Logfile: MSIc3130.LOG

Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action DoInstall, location: C:\WINDOWS\Installer\MSI4045.tmp, command: /silent /install "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&appname=Microsoft Edge&needsAdmin=True&usagestats=0&ap=stable-arch_x64" /installsource enterprisemsi /appargs "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&installerdata=%7B%22distribution%22%3A%7B%22msi%22%3Atrue%2C%22system_level%22%3Atrue%2C%22verbose_logging%22%3Atrue%2C%22msi_product_id%22%3A%22DCF62978-E764-38B6-8D70-FD4BFF0EDEE5%22%2C%22allow_downgrade%22%3Afalse%7D%7D"

 

Other issue: https://techcommunity.microsoft.com/t5/enterprise/installing-microsoftedgebetaenterprisex64-msi-erro...

 

Could someone help us out finding a solution to the install failure?

14 Replies

@SanderVR Your solution in finding lies in finding the difference between the systems that have the deviation (57) and those that have not (240).

1722 usually means that a object or action in the msi could not be completed. 

I suggest looking at software that is on the IS systems versus the IS NOT systems.

* Is there already a Edge Chromium present on those systems?

* Maybe Adobe Flash is installed on the 54? Which cannot be removed without manual intervention?

 

reg, Henno

I have the exact same problem here, but using Edge 80.0.361.66.

No Adobe Flash, and no Edge Dev/Beta, just the default classic Edge distributed with Win10 1903.

I'm not sure what other installed software might block the Edge installer, any suggestions?

 

Best regards

 

@tjoanp 

 

i had this error with machines not enough space on c:\. so this error is just an something went wrong flag and doesnt say anything about an possible resason

@Henno_Keers 

Thanks for your reply. It is a good starting point, but we can already check these from the list:

- No Adobe Flash

- No previous Edge Chromium installations (as this is an initial deployment)

- No lack of available space on C:

 

Further more, there shouldn't be much difference between these systems.

 

Apparently I am not the only one facing this issue, according to the reaction of @tjoanp 

 

To be sure it is not caused by any system files being corrupt, I will run a DISM / SFC scan on one of the affected systems and try again. Will keep you guys posted... 

I ran "DISM /online /cleanup-image /restorehealth" with success and a "SFC /scannow" finished with a reboot. The SFC scan found errors and repaired them, but unfortunately this did not solve the install issue for me.
best response confirmed by SanderVR (New Contributor)
Solution

Today I retried the MSI install on a computer where it failed last week, and this time the installation went through without any hazzle. The only thing I *know* had changed was that the 2020-03 windows patches had been installed.

@tjoanp  Thanks for your reply! I sure owe you a beer :happyface:

 

After installing kb4541330 (2020-03 Cumulative update for Windows 10 1709 x64) - which is about 1050MB in size! - The same Edge Chromium build installed without any issues..

 

As these 2020-03 updates are now being deployed to the farm anyway, I expect hope the issue to resolve itself! :cool: Let's see

 

Thank you all for your responses.

 

Greetings

Sander

@SanderVR 

 

We have the same issue in our enterprise. Ever since version 80.0.361.109, clients that previously had the Edge Beta enterprise installed will fail to install the enterprise MSI anything from 80.0.361.109 

 

Our last successful deployment that was largely successful to devices was 80.0.361.69. Ever since version .109, the MSI fails on the same step as yours. (See at the end of this post for the log). 

 

My additional troubleshooting steps I took that didn't work:

 

  • Manual uninstalling and gutting out Edge and EdgeUpdate files, registry entries, and services (sc delete servicename) didn't help.
  • Installing the enterprise MSI of version 80.0.361.69 fails as well now, even after everything was manually removed
  • Installing the newer MSIs also fail, same MSI errors as below.
  • Disable group policy that blocks automatic updates from EdgeUpdate (and also deleted the registry items for the respective policies to EdgeUpdate)

 

This is the only thing that has worked for me so far:

  • Install the latest Edge Beta Enterprise MSI
  • Take the EdgeUpdate command that is from the MSI log that failed, and run the command manually to install Edge 81.0.416.53 (yes that entire block is one command... and running it manually works where the MSI fails to work).

 

C:\Program Files (x86)\Microsoft\EdgeUpdate\MicrosoftEdgeUpdate.exe /silent /install "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&appname=Microsoft Edge&needsAdmin=True&usagestats=0&ap=stable-arch_x64" /installsource enterprisemsi /appargs "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&installerdata=%7B%22distribution%22%3A%7B%22msi%22%3Atrue%2C%22system_level%22%3Atrue%2C%22verbose_logging%22%3Atrue%2C%22msi_product_id%22%3A%2249DCD999-3A4A-30D9-8B5B-F1312CEFAB12%22%2C%22allow_downgrade%22%3Afalse%2C%22do_not_create_desktop_shortcut%22%3Afalse%7D%7D" 

 

 

Here is the snippet from the MSI log that are failing.

 

 

CustomAction DoInstall returned actual error code -2147219674 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (A8:D8) [08:58:53:562]: Note: 1: 1722 2: DoInstall 3: C:\WINDOWS\Installer\MSI502B.tmp 4: /silent /install "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&appname=Microsoft Edge&needsAdmin=True&usagestats=0&ap=stable-arch_x64" /installsource enterprisemsi /appargs "appguid={56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}&installerdata=%7B%22distribution%22%3A%7B%22msi%22%3Atrue%2C%22system_level%22%3Atrue%2C%22verbose_logging%22%3Atrue%2C%22msi_product_id%22%3A%2249DCD999-3A4A-30D9-8B5B-F1312CEFAB12%22%2C%22allow_downgrade%22%3Afalse%2C%22do_not_create_desktop_shortcut%22%3Afalse%7D%7D" 
MSI (s) (A8:D8) [08:58:53:562]: Note: 1: 2205 2:  3: Error 
MSI (s) (A8:D8) [08:58:53:562]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1722 

@Senturion33 

 

Hey,

 

had the same issue with the newest msi Version. 

 

Just found out there is a new parameter added for the msi Installer:

https://oofhours.com/2020/04/16/deploying-edge-without-a-desktop-shortcut-the-easier-but-not-easiest...

 

Added the parameter "DONOTCREATEDESKTOPSHORTCUT=true" to my PSADT Script and it worked.

Works with "false" as well! 

 

Maybe it will help you too ;)

Hi @Senturion33, if you're still facing this issue, could you send MSI command you ran, and the following EdgeUpdate log from a machine where the Edge MSI failed? %ALLUSERSPROFILE%\Microsoft\EdgeUpdate\Log\MicrosoftEdgeUpdate.log

For Edge Stable, the latest Windows updates listed in this link are required for it to install, so it's possible you were hitting that error; Edge Beta does not have this requirement.

 

@michli 

 

Thanks! I will check for that log on Monday from a problem computer. As a workaround, I enabled automatic updates for Edge so that clients could at least get updated. I'll see how the deployment looks with the current release of Edge MSI.

 

The command I am using to install Edge:

 

msiexec /i MicrosoftEdgeEnterprise64.msi /qn /norestart /log %temp%\update.log

 

 

 

I found that once I changed group policy settings from disable all automatic and manual updates and instead changed to allow manual updates only (by going to Help -> About), the MSI installs properly with 100% success rate across all client systems.

@Senturion33 thanks for following up, yes setting it to allow manual updates will allow you to install newer MSIs.

Click Start > Run. Type “Services.msc” without quotes and press Enter.Find Windows Installer and double click on it.Set the startup type of windows installer to manual.Click Start to Start Services and click OK.@SanderVR