Home

Error applying retention policy in security & compliance - "Recipient not Found"

Frequent Contributor

Error applying retention policy in security & compliance - "Recipient not Found"

I'm trying to create a retention policy in the Security & Compliance center, but running into an error.  The policy seems to create successfully, but after a while if I open the details it will show a warning sign next to '1 distribution results found'.  Expanding that area, it looks like there was a problem applying the policy to exchange, with the message of "recipient not found".  As you can see below, it's not terribly informative:

image.png

 

Has anyone else seen this error?  Do you know what causes it, or how I can get more info to troubleshoot?  

 

<rant>I tried contacting support about this using the handy "notify support" link next to the error, but the rep didn't seem to understand what my goal was, much less understand this problem.  He said that the error is because exchange mailboxes have a max size of 100gb and if I set a retention policy to keep everything forever, mailboxes will be over 100gb and that causes this.  Then he tried to steer me towards creating a retention policy in the exchange admin center that moves content over 1 year old to archive.  Ugh... not the point at all.  </rant>

15 Replies

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Havent seen the error, but it certainly looks like something on the backend, problem with synchronization maybe. Ask the support guy to escalate...

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Did you apply the policy to all Exchange mailboxes or just selected mailboxes? If selected, do all the selected mailboxes still exist?

Re: Error applying retention policy in security & compliance - "Recipient not Found"

When creating the policy, I chose the option to apply to it to "All Locations.  Includes content in Exchange email and public folders, Office 365 groups, and OneDrive and SharePoint documents." With that selected, there is no option to filter by mailbox. 

 

 

Re: Error applying retention policy in security & compliance - "Recipient not Found"

I have the same problem.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Me too - exactly the same problem...

 

The "Notify Support" link is pointless - it looks like a generic suggestion form.

 

I plan to open a Support Case today, so if I get anything useful by way of an explanation, I'll share it.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Same here, let us know how you go with support.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

So I opened a case today, and though the support rep that I spoke to hadn't seen this specific issue before first-hand, some of his colleagues had, and they speculated that since we're mid migration to O365 (we're running a hybrid setup at the moment with Exchange 2010 on prem) it could be that the policy isn't able to apply itself fully, to as yet un-provisioned/un-migrated mailboxes. Hence the brilliantly descriptive error message...

 

Don't know if this stacks up with your situations too? or if you're all fully migrated/consuming O365... but the chap has provided me with his details, and advised that we complete our migrations first, and see if the error resolves itself once all mailboxes are provisioned/migrated, and if not, to reach out to him for further investigation.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

We're 'fully migrated', but of course once you go hybrid, there's no going back, so we still have an Exchange 2013 server in the mix.  All of our mailboxes were migrated a year or more ago, with the exception of 3 mailboxes associated with our on-prem exchange and sharepoint administrator accounts.  I wouldn't expect those to cause a problem for the retention policies, but I suppose it's possible.  

 

Of course, if this issue is as simple as a few specific mailboxes that the policy failed to apply to, I would expect that support could have identified and explained that, but. . . 

Re: Error applying retention policy in security & compliance - "Recipient not Found"

I have this same issue and we are not hybrid - 100% cloud as we migrated over from Google. My case is open and the support tech advised I toggle the location for Exchange on/off. The error disappeared - for a day. Now it's back. We really need to know what it means - according to the mouse over - it could mean that the retention policy is skipping over the location (all of exchange?) or is it just the one recipient not found? Why can't we drill for details to see which mailbox? My support person is also investigating public folders - which I find laughable given that we have never used any (once again, coming from Google) and don't have a single one configured. Anyone have any progress on this? 

Re: Error applying retention policy in security & compliance - "Recipient not Found"

I have this issue too. And to eliminate the hybrid I tried to create the same policy in my test tenant that has no dirsync or on-prem connection, and I get the same error.

 

Creating the policy I also choose "All Locations" but it seems to change it automatically.

 

So lets hear from someone that fixed this :)

Re: Error applying retention policy in security & compliance - "Recipient not Found"

I have the same error, running the below command shed a little more light on the issue:

Get-RetentionCompliancePolicy -DistributionDetail | fl

 

The relevant part of the results:

DistributionStatus : Error
DistributionResults : {[Exchange]AllPublicFolderUnderRoot:Recipient not found: }

 

I disabled Public Folders in the retention policy, and now it has "On (Success)" as its status.  I wonder if the error occurs because we don't have any public folders, so the null trips up some code somewhere.  I just implemented the change, so I can't verify that the mailboxes were all put on hold.  At least the retention policy no longer has an error, so that's promising.

 

Re: Error applying retention policy in security & compliance - "Recipient not Found"

That definitely looks like improper error handling in the code... Open a support case to report it IMO.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Obviously this ppl is choosing to al folders but they dont have public folders so this cause a loop

Re: Error applying retention policy in security & compliance - "Recipient not Found"

Using the Powershell I described earlier to ID the "missing recipient" and correcting it (turning off Public Folders) worked for me.  I can confirm all of the users in our tenant are covered by the retention policy.

Re: Error applying retention policy in security & compliance - "Recipient not Found"

You will get this error if you have hybrid public folders (public folders on-premises) or if you have never created public folders either - like the example about migrating from Google by @Angel above.

If you have on-premises public folders, then either leave the retention policy in place (and showing an error) and that way when you do migrate your public folders they are covered from day one. Or remove public folders as a retention source. See https://c7solutions.com/2018/02/office-365-retention-policies-and-hybrid-public-folders for more.
Related Conversations
Problem to start Teams in the browser
André Diekmann in Microsoft Teams on
8 Replies
Formula
jmickey15 in Excel on
2 Replies
Error bars basic question
Sahar Ghanem in Excel on
3 Replies
Forms down? Error Code: 1003
Marketing null in Microsoft Forms on
7 Replies
Planner won't load in Teams
Brandon Laferriere in Microsoft Teams on
10 Replies