Unable to install Windows 11 - Getting BSOD

Copper Contributor

I've tried twice now to update to Windows 11. It gets through the initial download in Windows 10 just fine, but when it reboots and starts updating I get a BSOD: attempted write to readonly memory.

Rebooted, it failed and undid the changes. Tried again, same issue, but this time it attempted to recover the install, then failed. Repeated a few times (scaring the crap out of me, reinstalling OS is a pain) and finally undid the install like last time and it's back to normal.


I actually do want to try installing it, but only with the option to revert, so I'd really prefer it this method over a a fresh install.


See attached for screenshot.

5 Replies




the most secure is to download the update assistant - it will leave your personal files and applications unchanged, the next step is to download the ISO , but do not write yourself down

Update Assistant - does not work immediately!



So the only thing I can do if the update assistant is bluescreening me is to fresh install?




Of course, a fresh installation will fix everything!

But the second step is to download the ISO and run the exe manually.

Try updating all your apps in the Microsoft Store.

Remove outdated software, and you can uninstall temporarily before upgrading 

Antivirus if it is a third party