PL2303 issues (Prolific USB to Serial Drivers) Win 11

Occasional Contributor

I have come across an issue that I don't if anyone has come across and found a fix?


I have a few handheld radios that I need to update the frequencies and when I connect to the USB, it fails to connect. In device manager and Ports it says - "Please install corresponding PL2303 driver to support Windows 11 and further OS" 


I have tried different ways and still it won't update drivers/COM ports. I've run out of ideas (as for a novice).


Has anyone been across this and sorted it?





8 Replies
I have the same problem, and cannot find anything the solves it. The workaround suggested by BHITSSD did not help (I have no "older" versions of the driver installed to select).
best response confirmed by Cundy66 (Occasional Contributor)

I tried the older driver available here:
And this seemed to work for Windows 11. Weird that an old driver works better than the latest one.

I have the PL-2303 TA chipset.


Hello! You've posted your question in the Tech Community Discussion space, which is intended for discussion around the Tech Community website itself, not product questions. I'm moving your question to the Windows 11 space - please post Windows 11 questions here in the future. 

That has worked thanks

As per @ejohanson, the older version resolves the issue. So this is how I did it:
I had the latest driver installed, and when I rolled back, it installed 3.9.1, which resolved the issue.




There is a working driver at, a bit down the page listed as "DCHU (for PC Vendors)". Getting it installed is a bit tricky, it seems. What I did is this:

First install the downloaded driver by unpacking the zip file and "pnputil /add-driver *.inf /subdirs /install" (the /install is probably not necessary) from the extracted "Win11_DCHU" directory. It will add the two driver packages to the driver store and tell you what oemXY.inf files it has assigned to them.

Then "pnputil /enum-drivers", and in the output look for Prolific drivers other than the ones from the previous step. I had only one other entry, a "ser2pl.inf" version "09/16/2021".

Disconnect the device, and "pnputil /delete-driver oemXY.inf" with the INF file you located in the previous step.

Connect the device again, and it should work, at least, it does for me. The problem is probably that the non-working driver is the newest (September 2021 vs. July for the ones from the download page) and so Windows prefers it over them.

@chrullrich  Thank you, this worked for me also. But won't Windows update put the newer driver back again? Can I prevent that from happening?