KB5022913 some 20hr later DNS just stopped.

Brass Contributor

Not sure if its just a one off but my PC just stopped allowing DNS out ICMP , ARP and DHCP was fine, in the end I rebooted the PC and it all started working again weird.

22 Replies
Did you download or install any program before this problem started?
Check Windows Update history and there might be related update (for example related to network driver).
Their was a ASIX - Net – (USB to 1Gb) update but thats not the NIC I'm using for internet which is a Marvell AQtion 10Gbit Network Adapter is my main and I have many VLANs by Hyper-V on Intel I225-V with a backup 4G
I suggest have a look at log files in the Event Viewer , so you might find some clues there. Sometimes, you will observe this behavior if a service stop responding.
Can't find anything in logs before I did a reboot as to what caused it
Was there any other device connected that time?
If yes, did you observed the same behavior?
If you mean could a access the internet on another device the answer is yes
happened again! tried ipconfig /flushdns but still ended up rebooting
Check for update for your network driver.
Try open start and search for feedback and open the Feedback Hub app and report this issue.

Yes driver is upto date I have reset the Winsock and done my VLANs so I see what happens.

As for the Feedback Hub app and report this issue that never helps.

Thinking it some weird driver issue with Marvell on 3.1.7 as I have another system on 3.1.3 without problem so have rolled back
Thank you for sharing.
Have you tried performing Clean Boot and see if the problem persists?

I did a reboot and I'm just waiting to see if it happens again or I be doing a reinstall :unamused:

Before reinstalling Windows, try Clean Boot and share the result.
By Clean Boot you mean a shut down and power up? As said I did a reboot or is that not enough?

As if this was not enough MS decided let push Marvell on 3.1.7 out to everyone! Was not a optional driver so now I have to roll back to 3.1.3:facepalm:

Does that solve the problem?
It can take about a week when it happens so I let you know in 7 days
No worry, please observe the behavior and let us know about the result.
Been stable for a week so the problem must be Marvell on 3.1.7 causing the problem.