Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

Canon MP Navigator EX 1.0 for Canon PIXMA MX310 on Windows 11

Occasional Contributor

Can Canon MP Navigator EX 1.0 for Canon PIXMA MX310 on Windows 11? It keeps telling me to check the connections. I used to work it on 

12 Replies
Does it work in the Windows 10?
Have you installed the latest version?
Try check with the Canon's support.
Meanwhile, report this issue using the Feedback Hub app.
It worked on Windows 10. It’s okay I am going to buy a new scanner / printer. I tried so many things nothing worked.

Thanks
Have you tried contacting the Canon?
Make sure file this issue using the Feedback Hub app so the Windows team would be able to investigate it.
Not really. Their website doesn’t support older version printers / scanners. Probably want us to buy their newer models.
Are you facing any problem when you are installing the driver?
Actually it started to work. I was shocked. Before it told me to check the connections.
I wanted to ask when I try to make my printer as the default printer there was a warning came up as “ If I setup as default then Windows will stop monitoring my printer”. Why did that message come up? Do you know?
Do you have screenshot of this message?
If yes, please reply to this post and paste it.
I want to see if this message is from the Windows or the Printer?
I attached the picture with the message. Keep me posted.

@RoGirl666 

 

Now my printer is telling me it's offline. I keep checking the connections and there is nothing wrong with that. What's going on with my printer?

The message in the screenshot is from the scanner and not the Windows.
Did you download and install the latest version of the application and the driver.
Make sure report this issue using the Feedback Hub app.
You may run the application in compatibility mode, take a look at:
https://support.microsoft.com/en-us/windows/make-older-apps-or-programs-compatible-with-windows-10-7...
I didn't have printer issues when I had Windows 10. It only started when I upgraded to Windows 11. I shall try your link and see.
Try report it and use the link to run it in the compatibility mode.
You may share it with the Canon's support too and they might have a workaround.