After updating to Windows 11 existing PIN not available (asks for a company account)

Copper Contributor

I have a personal DELL notebook bought with Windows 10, registered to me and my personal Microsoft Account. I also work at a University that uses Microsoft 365 and I use my company account for apps (Teams, PowerPoint, etc.). I set up Windows Hello on Windows 10 with fingerprint recognition and a PIN.

After updating to Win 11, the Windows Hello fingerprint scan option works fine, but the PIN option is no longer available, a message appears underneath the option:

"Sorry, this PIN isn't working for your organization's resources. Tap or click here to fix it"

When I click, it asks me to log in with a company account to set it up (doesn't allow me to use my personal Microsoft Account).

Why is Win 11 telling me "this PIN isn't working for your organization's resources" when I only want to use it to access my PC (which, again, is registered with my personal - and not my company's - account)? While on Win 10, the PIN was correctly working...

What would be the best course of action here to enable again the PIN option?

6 Replies


Try FIX 1 mentioned here:

Let us know if this helps!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

@Kapil Arya thank you very much. I tried the fix, but I was only partially successful.

First off, I couldn't access the C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft folder from Windows Explorer. It only grants me access to C:\Windows\ServiceProfiles and from there I cannot open any subfolders. Note that my account has administrator privileges.

I can access the folder via cmd (run as administrator). I tried to take ownership of all folders and subfolders under ServiceProfiles using the following commands:


takeown /f C:\Windows\ServiceProfiles /r /d y

icacls C:\Windows\ServiceProfiles /grant administrators:F /t


But I still cannot open those folders from Windows explorer.

I renamed Ngc to Ngc.old via cmd and it did the trick to make the "sorry this PIN... etc." message disappear and let me set a new PIN. However, when I try to do that, after logging in with my personal account credentials and setting a PIN I keep getting a "Something went wrong" error.

Any suggestions?

Okay, try setting PIN from login screen, see if that works. Refer 2nd part here:


Also make sure, if you're signed in with Microsoft account, verify the account.

Keep us posted!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

Thank you again! Sadly, trying from login screen did not work either (same "Something went wrong" error). My Microsoft account is already verified.

EDIT: on top of that now the fingerprint scan isn't enough to log in and Windows tells me that my PIN is required to log in, forces me to log in via my personal account password, sends me to the PIN setup window and ends up with the "Something went wrong" error

Update: I am back to square one. I had to restore the Ngc folder since logging in all the time with the ordeal mentioned above was unacceptable, but my problem remains unsolved.
Try disconnecting the work account, see if that helps, in case if you've not tried this. If issue still persists, you need to connect with your IT admin to resolve the issue. Usually IT admins may deploy some policies to restrict you the system.