Boot fail: how to troubleshoot?

Brass Contributor

Hi all.  

I just wanted to double-check my troubleshooting thinking here, maybe I'm missing something in the modern era of Win 10.  

So a laptop with a 2.5" HDD first boots up and gives the light-blue screen with the QR code saying there was a problem with the computer.  It then shuts down.  There is zero useful error info on screen, though, I did not follow the QR code to see what it said.  


However, on powering it up again at the bottom during/after POST it gives the "diagnosing your PC" text as Win 10 will do anytime you have boot problems. 


Long story short, all methods to do repair fail.  System Restore does see restore points, to be able to utilize them I had to use cmd to start the vss service and then rstrui.exe /offline:c:\windows=active to be able to try to process them, but they all failed with "unspecified error". 


Reset this PC > Keep my Files fails, no specific error.  


So I've gone through all options in the startup diags screen for Win 10, both from the on-disk booted version and having booted from the USB WinRE thingy (Win 10 Media Creation Tool).  


FWIW I went into the BIOS and boot mooe is UEFI.  Set it to Legacy just to see, and that completely fails to even start to boot so i reversed that.  


I was able to successfully clone the hard drive (took it out, docked to a duplicator).  And I can access the data and see no signs of problem if I mount the drive to a working computer.  A full virus scan on this docked drive also came up clean, though I do realize there could be more deeply embedded/encrypted malware, but for arguments sake let's say it's clean.  


Am I missing some key Win 10 boot sector /fixmbr trick or something?  I began to follow some command prompt guidance on running these bootrec commands.  /fixmbr says it did so successfully, no change to issue.  /fixboot said "Access is Denied".  The other two bootrec both say they see 0 Windows installations, yet I can easily browse to the Windows folder on the C:


I tried to do this "diskpart /s scriptname.txt" thing so I can run diskpart > select disk 0 and maybe some other commands to follow, but apparently that command doesn't work as advertised because I would specify it on the computer having issues and it would just say it can't find the file.  


My assumption is that the USB boot environment, under the Startup Repair section, tries to do all this mbr/partition type stuff anyway so it's a waste of time doing it manually.  Would that be correct?  You never know with MIcrosoft though.  


Thank you.  

6 Replies
best response confirmed by ViProCon (Brass Contributor)
Hi, was your Windows 10 updated? the latest build is 1909 at the moment.
keeping an OS updated (Android, Windows, IOS etc) is itself a preventing measure to keep the OS running well.

I see you've done your fair share of troubleshooting and you can already salvage your data, also it seems refreshing/resetting Windows 10 from recovery environment fails for you too?
so may I suggest to do a clean install? you can always grab the latest ISO file from here, put it to USB and do the clean install:



I ended up having to do a clean install.  Had this been a hardware fault I expect I'd have had problems.  What annoys me about the Win RE is that why, if this is only a software issue, could it not have fixed that?  The concept of replacing corrupted file, and rebuilding corrupted partition/file system info should be fully integrated into the RE and yet it failed on all counts, and yet, it did see 4 System Restore points, and could even browse the full file system of C: with no issues.  So perhaps it's some screwy thing with those hidden partitions but let's just say that my confidence in the WinRE kind of went down here, even Reset this PC failed and that makes little sense since it all went to plan by me just wiping out partitions and starting anew.  


Ah well :)

Yes it also happened to me before when system restores failed, I no longer rely on restore points to keep me safe, not anymore, in my experience they can get corrupted easily.
although in the recent Windows 10 builds, since 2-3 years ago, refresh and reset never failed.
I can only imagine that when they are failing for you, it's probably because the internal image is corrupted.
Microsoft added a new option in Windows 10 to download the new image from the cloud, first appeared around a year ago on Windows insider but it will soon make it to the released ring


Yeah that's exactly what I thought was going to happen, I got the insider news on that but in my head I thought the feature was already part of the bootable media so I was puzzled why even that didn't work. But I bet you're right, the image was corrupted or inaccessible somehow.  Given that it would fail the Rest This PC process basically immediately, I suspect it was inaccessible to begin with, lending more credit to this being some kind of corrupted "something" in the file or partition/boot system, or maybe some general corruption just beyond those points.  


Needless to say I'm putting this system on a full system image backup plan.  


Thanks for all the good input!  

Anytime, hope you never experience such thing again!
I am having a Windows 10 boot failure on a Lenovo Ideapad Slim-1. It shows the Lenovo logo but after that goes to a black screen. Every so often when I hold the power down for a few seconds after booting below the Lenovo logo says Please wait and then it goes to recovery options or restart pc. I have tried to hold power down for 30 seconds. Did not do a thing to fix booting issue. My dad does not remember his login password. Can someone please help me. I did do one year of college in IT field so if you speak in a bit of technical terms I can understand but if I don't understand you I will ask to explain it a little more detailed.