Teams button click gives the error and it hangs.


On click of button teams gets hanged and I am not able to click anything else



18 Replies
Could you please share more details of which button you are clicking and also the steps so that we can try and repro this issue?


I am using this card to render. It's working all the time but randomly when I click button teams is hanged and action is not done.

{"type":"message","attachmentLayout":"list","attachments":[{"contentType":"application/","content":{"title":"Hello! The Daily Standup is about to start","buttons":[{"type":"invoke","title":"Begin","value":{"type":"task/fetch","data":{"message":"Hello! The Daily Standup is about to start","teamId":"19:PqY2oalEPDqKlOG9xxoOHhanG9pIo1@thread.tacv2"}}}]}}],"inputHint":"acceptingInput"}


Hi @Meghana-MSFT, Our issue is exactly similar to this

It's working for everyone except some random case and we are not able to reproduce. We are not getting any request to our server and we get these errors in console. when we checked card and button was correct. Can you please help us solve the issue and let me know if any further details required?

@AyeshaKulsumSJ- There is latest update for teams. Could you please ask them to update and check with latest version? you mentioned that issue occurs in random cases for some users, Are all the users on same Teams version?

Hi @Meghana-MSFT , Customer facing issue has latest version from the 24th of June and he is still encountering the issue. Issue exists from Microsoft teams app and also when opened from browser. 

@Meghana-MSFT I am just following up to check regarding the above issue. Issue still exists when button is clicked from APP or Browser and there is no API call sent to us but teams is getting hanged where I am not able to click anything after that. Either we have to reload Browser or reopen the app, I can help you with any further details required. Looking forward to hearing from you.

best response confirmed by AyeshaKulsumSJ (Contributor)

@AyeshaKulsumSJ - Could you please try downgrading the version to Microsoft Teams Version (64-bit)-E and check again. User in Teams freezes when user clicks on "task/invoke" button - Stack Overflow thread confirmed that it works for them. We also tried setting up a sample at our end and it worked. Please find the recording at -  

@AyeshaKulsumSJ - Could you please let us know if the above suggestion helped?


@Meghana-MSFT Can you send document to downgrade?

@AyeshaKulsumSJ - We see that the users in these threads, Teams freezes when user clicks on "task/invoke" button - Stack Overflow have confirmed the issue is resolved for them. Could you please check in the latest version of Teams? Meanwhile we are checking with the engineering team as well.

@AyeshaKulsumSJ - Could you please share recording of the issue repro. It would be helpful for as we do not have a local repro of the same. Thanks.

@Meghana-MSFT Link to video, The issue exists for Customer ACTINVISION. They have added two of our SurveySparrow Employees to their Organisation and shared Survey.
When we click on the Survey button, teams get hanged and an API call is not made to SurveySparrow as seen in the network tab. It's working for a few Clients in their Organisation.


@AyeshaKulsumSJ - Could you please help with the below ask?

The team is unable to setup whole flow of SurveySparrow app. Could you please provide test account where it is repro'ing? You mentioned the issue exists for Customer ACTINVISION. They have added two of SurveySparrow Employees to their Organisation and shared Survey. does it mean it is shared to external users?

  • @Meghana-MSFT  Can we make this thread private so that we could share details here or Can you share with us your email Id? Yes, they have shared Survey with external users(SurveySparrow Employees) to check the issue which is reproduced. And also when the survey is shared issue exists for only a few Employees(ACTINVISION) and it works for other employees(ACTINVISION).


Please share the details at

@Meghana-MSFT Thank you for your support. The customer responded updating to the latest version worked for them.

Thank you for confirming back.