Sharepoint list, data not showing in form but in list.

%3CLINGO-SUB%20id%3D%22lingo-sub-2834253%22%20slang%3D%22en-US%22%3ESharepoint%20list%2C%20data%20not%20showing%20in%20form%20but%20in%20list.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2834253%22%20slang%3D%22en-US%22%3E%3CP%3EHi!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EA%20strange%20thing%20happend%20today.%20I%20think%20it%20might%20have%20occured%20when%20I%20added%20a%20new%20item%20from%20%22row-view%22.%20But%20not%20sure.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyway%2C%20as%20can%20be%20seen%20in%20the%20picture%20below%2C%20the%20data%20from%20the%20list%20is%20missing%20from%20the%20form%2C%20but%20viewable%20in%20the%20list.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20might%20have%20happend%20and%20what%20can%20I%20do%20to%20fix%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20grateful%20for%20any%20tips!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-right%22%20image-alt%3D%222021-10-11%2015_54_26-Grot%20lager%20-%20Albin%20Lars.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F316496iDF6DF92B1D698119%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%222021-10-11%2015_54_26-Grot%20lager%20-%20Albin%20Lars.png%22%20alt%3D%222021-10-11%2015_54_26-Grot%20lager%20-%20Albin%20Lars.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2834253%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2891020%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20list%2C%20data%20not%20showing%20in%20form%20but%20in%20list.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2891020%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F715184%22%20target%3D%22_blank%22%3E%40bob_sacamano%3C%2FA%3E%26nbsp%3Bdid%20you%20have%20some%20response%20about%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2953950%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20list%2C%20data%20not%20showing%20in%20form%20but%20in%20list.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2953950%22%20slang%3D%22en-US%22%3EStill%20having%20this%20issue.%20I%20can%20edit%20an%20view%20all%20data%20in%20the%20%22edit%20in%20row-net%20view%22%20but%20not%20in%20the%20standard%20form.%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi!

 

A strange thing happend today. I think it might have occured when I added a new item from "row-view". But not sure. 

 

Anyway, as can be seen in the picture below, the data from the list is missing from the form, but viewable in the list. 

 

What might have happend and what can I do to fix it?

 

I'm grateful for any tips!

 

2021-10-11 15_54_26-Grot lager - Albin Lars.png

18 Replies

@bob_sacamano did you have some response about this?

@bob_sacamano 

I have the same issue happened to me this week, never had this problem before. 

Still having this issue. I can edit an view all data in the "edit in row-net view" but not in the standard form.
No responses, would very much appreciate some.
Occured to me again this week. Seams to be occurring when i work heavily on a list, like som overload issue. But now it persist, before it went back to normal over night.

@bob_sacamano Had it happened from time to time. When i erased the browsing history in Edge, the items were visible in the SharePoint Form. So i guess i'll be doing this until a solution is found.

 

Aha, that worked! Thank you so much! Now I don't have to contact my expensive IT-vendor just for some small thing like this.

I wish you a very good day Sir!

@bob_sacamano 

 

This matter continues to haunt me. For my users I insert the sharepoint list into teams, and now the same thing happens there. But how can I "clear history or cookies" from MS teams?

@Martin_Bilodeau I'm having the same problems in MS teams. I've added the list to a Team. But I how can I accomplish "clearing browser history" in Teams? 

I did this( cleared the cache) and it worked for a couple of minutes before it returned to the same issue. I've tested several browsers, Chrome, Edge, Firefox but all of them have the issue. I have not changed any settings for this list. I created a new view and suddenly it started to work but quickly returned to the issue. This is really frustrating.

@Nitramarbok That is also my experience. My belief is that I've accidently done something that messed up the links somehow. Because if I search the object and click on it in the "search proposals dropdown list" it Works, but if I press enter and click on one of the search results, the same problems appear. 

@bob_sacamano Same issue here, was this ever resolved?

Was this ever resolved. Just started happening to me last week!
I actually never got it resolved. I laid the project on ice.

Thanks @bob_sacamano for the reply.

Based on another comment in this conversation, I tried clearing browsing history.  Seems to be working for now.  I have communicated to our IT group and others that use SharePoint Lists at our company.

 

I'm so glad I found your post because I couldn't find much else out there about this.

@Dak-Dan 

 

I tried that also when I was testing but it only momentarily solved the problem. But perhaps that has changed. Will be interesting to see if it solves your problem permanently!

 

 

@bob_sacamano 

 

Right.  I still don't know how often I will have to clear the browsing history (every time I want to edit something?); and who knows if this will fail to work some of the time...

 

I'll post here if/when I learn anything more about this.

 

Thanks again!

Do you encounter any issues in classic experience? I am curious if there are some issues with modern experience that is causing these headaches, including the inability update and save a different content type on an existing list item.