Sharepoint Flow - Sharing Link Access Denied

New Contributor

Hi All, 


I'm hopeful for some help. I have a flow created which is triggered by a form submission, the information on the form is shared across a number of lists and there are 2 files stored within 2 Document libraries and then  a sharing link created and stored on a master list. This has been working without issue for a couple of months however Yesterday for some unknown reason the flow has been failing at the point of creating a sharing link. I tried to do this manually and there were no permission errors so tried to add a slight delay which didn't work. 

I've checked the permissions for me and I'm a full owner of the site and nothing has been changed since the original flow was setup. I have tried to create a simple version to create the sharing link and that fails for he same reason, although if I do it manually it fails.

Can anyone offer any guidance? Below image is copy of the error if this helps?



2 Replies
Where are you checking the permissions? I'm guessing that you're checking in SharePoint for the account but perhaps double check that the account you're checking against is the one that's running this step in the workflow.

There is also a test option within the Flow editor, which lets you run a test with previously submitted information. Can you execute a test against a successfully flow instance and see if its returns the same error.
Thank you for the response, yes I was checking Sharepoint for the permissions however i figured out that the site was originally setup (By someone else) as a subsite. The master site had updated their permissions which locked this flow out.

I've resigned to rebuilding the flows to another sharepoint site.