Migrate Libraries using ShareGate's Copy Site Object misses DispForm.aspx for the library

Copper Contributor


I've noticed an issue with using ShareGate's Copy Site Object to migrate SharePoint libaries from one SharePoint Online site to another.  I migrated the libraries without content. It's only after a while did I noticed that when I try to look at the property of any documents, I got the following error message: Unable to find the default display form.




I opened SharePoint Designer 2013 to compare the original and migrated library and found that the following forms are all missing.

DispForm.aspx, EditForm.aspx, Upload.aspx.


I looked at the migration report. There were indeed warnings about unable to create ListFormWebpart.


I clicked ont he How to solve this. It took me to a ShareGate page that suggested I should enable custom scripts on my SharePoint online environment. I did that.




Waited for over a week before attempting the next Copy Site Object action. The same thing happened. ShareGate missed the forms.


This is an issue because Not able to migate the library forms meant users cannot edit document properties. Not being able to use the Copy Site Objects function seriously limits the usefulness of ShareGate. Does anybody know how I can migrate these library forms? I tried to use the New button to create a new DispForm but I got an error that it cannot save the list changes to the server.



CreateNew List form.png


10 Replies
I think you should report this issue to Sharegate guys
best response confirmed by Louis Kwong (Copper Contributor)

Hi Louis,


Full disclosure, I work for Sharegate :) Here's what you need to do to resolve your problem:



1. Download and install Sharepoint Online Management Shell
2. Open a Sharepoint Online Management Shell prompt
3. Run the two following commands:
Connect-SPOService -Url
Set-SPOSite -Identity -DenyAddAndCustomizePages 0
4. Try to remigrate.


If that doesn't work, contact and they'll be happy to give you a hand! Good luck :)

Thanks Mia, I've tried it and it worked perfectly! It's so annoying with SharePoint Online that enabling script in the admin console is not enough. You had to use Powershell too. It worked. The migrated libraries now have the missing forms. It also solved another issue with the OneDrive iOS app. It can now see the migrated library. Before this, the OneDrive iOS app could not see the migrated libraries. I assume that's because of the missing forms. Thanks again.

So happy it worked! If ever you have any other questions, don't hesitate to contact our support team :)

I have this same issue, just trying to understand, would the migration tool just migrate the lists and contents but default to the new/edit pages on SharePoint Online?


I will run the below.  thanks!

Hi Jonathan!


If you are only copying the content of your site (Copy Content), then yes it is possible. If you copy the full structure of your lists and libraries in your Site, the pages will also be copied. Hope this helps!


If I understand your process you would have to run this script on every single site?

Does Microsoft plan on creating an API for the modern lists and libraries so that ShareGate will be able to copy lists/libraries to modern lists/libraries?  it is a pain point for our current migration.  For Each list online, I am creating a new app, adding and setting columns (re-creating the list), the using migration tool to migrate content.

Thanks for the information. In my case I had already deleted the source and the forms weren't that important that I would worry about losing them.

It appears the forms are copied across but the link from the list to the forms is missing. In my case I used designer to browse all files and lists and delete the original forms. I then used Designer to re-create the forms.

If you didn't want to delete the migrated forms, you could just recreate with a different name, using Designer.

@Mia Lohé Chung Thanks for your solution because we had the same problem for duplicating our CRM community.the other unsolve problem is that after duplicating the drop-down menu doesn't migrate. any solution?