Excel App opens old Version of document saved in Sharepoint Online

New Contributor

I am not quite sure if It's a sharepoint online or an excel problem. If I open the excel document with the online excel version, it will show me to correct last saved version of the document. If I open the document with the app (excel program on my computer) it shows me an old version with the hint that there is a new version on the server. Any suggestions inside the program to solve the problem don't work. It will still open an old version. 

 

Do you have any suggestions for me?

7 Replies
Sounds like a file sync issue. Do you have the library sync'd to your local computer? Check the OneDrive client to see if there are any file sync issues.

What happens if you right click the document in the Browser and choose Open with App? Does that open the correct version?
The file (library) isn't sync'd to the computer. When I click the document in the Browser and choose Open with App, it will show an old version, when I choose open in browser (the online version of excel) then I'll see the correct version.

Hi, I have the same issue. Was it solved? For me it re-ocurring  with some files.

thanks

I have the same issue. I have tried many things to fix this but cannot resolve this. I need to be able to open this file in the app because the filters in the browser show limited results and this hinders me from finding errors. I need this resolved so I can open the current file in the app. Thanks in advance for finding a solution.

This resolved the issue for me. I had to open another Excel file to do this and save, since my messed up file could not be saved.
https://www.mrexcel.com/board/threads/working-from-sharepoint-cache-issue-discard-changes-fix.116321...
Here is the text from the post.
"Hi Luke777, hope your issue had got resolved. I had faced exactly the same issue. It needs Office Document Cache to be cleared in order to fix this which is available from File --> Options --> Save --> Caching Options. Checking the box " Delete files from the office document cache when they are closed" fixed this issue."

@GernDog thank you so soo much! That helped me too :) 

@GernDog is the man, this helped me out too!