Error: Invalid statement, ResultCode: 1

Brass Contributor

This is weird, all of a sudden I am getting this error and cannot create a SharePoint list.  anyone encounter this?  What is the issue here? 




18 Replies

@VeeExcelLearn Did you or anyone else added column validation or list validation on this list?


All users are facing this issue or just you?

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like. seems like it resolved all of a sudden..Maybe it was something temporary. Not sure but the message went away after 10 minutes.

@VeeExcelLearn Great, glad it is working for you now!

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.


I am getting this error and it hasn't gone away in over 24 hours. To my knowledge nothing has changed in my SharePoint list. I now can't add or edit any items.

Mine went away after a I suspect Microsoft was doing something in the background.

@VeeExcelLearn The issue went away after two days, but it's just come back and I haven't been able to edit or add items to my list since yesterday - really wish I knew what was going on here...

If anyone else is having this error, I have found that opening the list in an "incognito" window in Chrome fixes the issue for me. So not sure if the error is about authentication, but hopefully this can help others.

I had the same issue and had "Rss View" appear in my All Item View drop down.


When I went to incognito mode initially the "Rss View" was not present and the list acted appropriately.  I just went back and it appears now and the list does not function appropriately.  I get the following when editing in Grid View.



and the full edit view is blank.


I cleared cookies and browsing and similarly it worked and then did not work.

I even have RSS turned off and it appears.

I am all ears on a fix.

@JSPatelMD were you ever able to resolve this issue?  I have the same issue, and clearing the cookies in the browser TEMPORARILY works but then the issue comes back.

@VeeExcelLearn I'm having the same problem.  Was this ever resolved?

@JToddStewart Any updates? Ours just started this today and it's only certain list that are affected.



We used the ignognito session to launch the view (we could do it though from the Classic Sharepoint View as well though, in which the list was visible).

Edit current view > Added a field, for example color tag > saved the view and refreshed.

It works!
We then removed the field again and it worked as well.

The above means that SharePoint UI has lost sync with the dataset on the back.
Perhaps we could have the same resolution if we used the re-index functionality in the list settings but I did not test it.

Re-indexing the list fixed it for me.

Did re-indexing the list fixed the issue permanently ? Like the rest here, I refreshed browser including deleting history and cookies, it resolved it only for the current session. The error returned after opening a new browser session.


My company has this error too. It started at one client and spread after clients recieving software updates.

After doing some log debugging I pinpointed the bug to CORS.

After the initial list/page has been shown, the following pages and lists fails. It seems like CORS deems locally cached files unsafe and thus blocks them, but fails to fetch from original source (

I tried multiple tests with Chrome with the setting -disable-web-security and with CORS killed, Sharepoint works again.

You can try a workaround with the above or installing the browser extension CORS unblock, but it will lower security - use it at your own risk.

The error persists over multiple browsers pointing to Microsoft Sharepoint as being the culprit.

Did you get this resolved? I'm now experiencing this same issue.....rats!


My supplier of Sharepoint solutions fixed it this way (translated from Danish):

"We updated fieldtypes on userfields that is able to hold multiple valuetypes, to be of the type UserMulti in stead of User in the fields SchemaXML".

Hope it works for you too.

For us, the most common culprit for this Error: Invalid statement, ResultCode: 1 has been when the list is set with "Offline Client Availability"
As long as no one using this list needs to be able to access the list offline, I personally recommend changing "Offline Client Availability" to "No" to avoid headaches with local caching
This setting is in List settings > Advanced settings 

scroll down to "Offline Client Availability" and set it to "No"


Don't forget to click OK at the bottom to save the change.

Hope this Helps!