Channel folder cannot be deleted

Brass Contributor

Hi community

There are channel folders they cannot be deleted. the channels have already been deleted in Microsoft Teams.


The channels are deletedThe channels are deletedhere is no delete buttonhere is no delete buttonconnected to an channel ... ?connected to an channel ... ?

Tried to delete the folder with "Sharegate"




  1. Why are the folders not deletable?
  2. How can I delete this folders?

Edit: Similar topic, but no solution: Unable to delete a folder "abandoned" after channel deletion - Microsoft Community

Regards, Simon

29 Replies
Thanks for this idea Ruben. Off of this I decided to try renaming the folder. That worked. I just renamed the folder and the delete option came up. Hope this helps someone save some time!
I did not try the rename solution, but I had a similar situation where a channel had been deleted and the folder was still in Documents. Because of how folders show up in SharePoint Online now as either "In Channels" or "In Site Library" (my trouble was in the In Site Library), creating a new channel with the same name and deleting it didn't work. However, I was able to go to the site library, click "Edit in grid view" and delete the row with the troublesome folder, and that did actually delete it!
legend! thanks for the fix!
I also had this issue with an orphaned channel folder in SharePoint Online. My solution was to create a channel again with the same name. The new channel was mapped to this existing folder. Then I deleted the channel again and then the folder was "free" and delete in the menu available.

My solution was by renaming the channels in Teams before deleting it. Then I was able to delete the folders from SharePoint.

worked for us, too. @Lars Thanks for sharing your reply.
Thank you Ruben_Jobse.
So relieved to find the solution.
Indeed some folders have been created by creating a channel. Sometimes if you copy those folders to another sharepoint, it won't let you modify because they are missing their twin channel.
Best and simplest solution! Many thanks.
I didn't get to try all the other fixes, but found if you switch the library to display in classic view the delete option returns
Excellent, worked for us and super easy. We had no delete, rename or move items on the context menu. Opened in grid view, selected the folder and pressed delete. Voila.