SOLVED

Cannot update Hub Site Navigation

%3CLINGO-SUB%20id%3D%22lingo-sub-252314%22%20slang%3D%22en-US%22%3ECannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-252314%22%20slang%3D%22en-US%22%3E%3CP%3EAnyone%20else%20having%20issues%20today%20updating%20Hub%20Site%20navigation%3F%26nbsp%3B%20Tried%20Different%20Browsers%2C%20Users%2C%20Computer%2C%20existing%20and%20New%20Hub%20site...%20I%20make%20the%20change%2C%20hit%20Save%20and%20nothing%20changes.%26nbsp%3B%20I%20opened%20a%20ticket%2C%20trying%20to%20figure%20out%20if%20anyone%20else%20is%20having%20the%20same%20problem%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-252314%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHub%20sites%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-266816%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-266816%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F193276%22%20target%3D%22_blank%22%3E%40Du%20Le%3C%2FA%3E-%20thank%20you!!%20I've%20also%20reached%20out%20to%20Microsoft%20to%20see%20if%20the%20afore-mentioned%20fix%20had%20been%20pushed%20out%20to%20early%20release%20customers%20only%20and%20if%20they%20can%20check%20our%20tenant%20to%20see%20if%20we'd%20received%20it.%20I%20really%20appreciate%20the%20PS%20script%20below%20-%20it's%20not%20my%20forte%2C%20so%20this%20is%20helpful.%26nbsp%3B%20Thanks%20again%2C%20Laurie%3C%2FP%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F193276%22%20target%3D%22_blank%22%3E%40Du%20Le%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F112665%22%20target%3D%22_blank%22%3E%40Laurie%20Petrick%3C%2FA%3E%26nbsp%3Bit%20looks%20as%20though%20I%20am%20also%20in%20the%20same%20boat%20and%20the%20previous%20workaround%20no%20longer%20works%20so%20I%20have%20resorted%20to%20using%20PowerShell%20to%20manage%20the%20navigation%20so%20if%20you%20can't%20wait%20for%20MS%20to%20fix%20the%20problem%20look%20at%20using%20the%20following%20PnP%20PowerShell%20cmdlets.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EGet-PnPNavigationNode%3C%2FP%3E%3CP%3EAdd-PnPNavigationNode%3CBR%20%2F%3ERemove-PnPNavigationNode%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20will%20need%20to%20install%20the%20SharePoint%20Online%20PowerShell%20module%20in%20order%20to%20do%20this%2C%20there%20is%20the%20link%20%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%3C%2FA%3E.%3C%2FP%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-266605%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-266605%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F112665%22%20target%3D%22_blank%22%3E%40Laurie%20Petrick%3C%2FA%3E%26nbsp%3Bit%20looks%20as%20though%20I%20am%20also%20in%20the%20same%20boat%20and%20the%20previous%20workaround%20no%20longer%20works%20so%20I%20have%20resorted%20to%20using%20PowerShell%20to%20manage%20the%20navigation%20so%20if%20you%20can't%20wait%20for%20MS%20to%20fix%20the%20problem%20look%20at%20using%20the%20following%20PnP%20PowerShell%20cmdlets.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EGet-PnPNavigationNode%3C%2FP%3E%3CP%3EAdd-PnPNavigationNode%3CBR%20%2F%3ERemove-PnPNavigationNode%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20will%20need%20to%20install%20the%20SharePoint%20Online%20PowerShell%20module%20in%20order%20to%20do%20this%2C%20there%20is%20the%20link%20%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-265809%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-265809%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%2C%20will%20do.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-265752%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-265752%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F111857%22%20target%3D%22_blank%22%3E%40Laurie%20Petrick%3C%2FA%3E%26nbsp%3B-%20Mine%20was%20fixed%20a%20couple%20weeks%20ago%2C%20the%20workaround%20(Go%20Site%20Contents%20and%20then%20edit)%20also%20worked%20for%20me.%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3BIf%20you%20are%20still%20having%20problems%20then%20try%20a%20different%20browser%2C%20and%20if%20that%20does%20not%20work%20I%20would%20open%20a%20ticket%20with%20MS%20to%20see%20if%20your%20tenant%20got%20missed%20with%20the%20patch.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-265748%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-265748%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20still%20experiencing%20this%20issue%20-%20I%20do%20not%20believe%20it%20has%20been%20fixed%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F142545%22%20target%3D%22_blank%22%3E%40Daniel%20Schmidt%3C%2FA%3E.%20I%20have%20a%20hub%20site%20with%20navigation%20defined%20and%20am%20trying%20to%20edit%20the%20URLs%20within%20each%20menu%20item%20-%20some%20update%2C%20others%20do%20not.%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F142545%22%20target%3D%22_blank%22%3E%40Daniel%20Schmidt%3C%2FA%3E%26nbsp%3Bre%3A%20work-around%2C%20I%20cannot%20edit%20the%20URLs%20from%20the%20Site%20Contents%20or%20a%20document%20library%20-%20I%20can%20add%20links%2C%20but%20not%20modify%20them.%20From%20the%20home%20page%2C%20sometimes%20the%20'Save'%20button%20works%2C%20other%20times%20it%20appears%20to%20work%20but%20then%20does%20not%20close%20the%20menu%20-%20leaving%20only%20the%20option%20to%20'Cancel'.%20I%20do%20not%20receive%20an%20error%20in%20either%20case.%20When%20the%20'Save'%20button%20appears%20to%20work%20(saves%20and%20then%20closes%20navigation%20editing)%2C%20not%20all%20updated%20links%20are%20actually%20saved.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-255193%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-255193%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWorkaround%20worked%20and%20MS%20has%20fixed%20it%20now%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-252596%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-252596%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20can%20edit%20the%20hub%20site%20navigation%20by%20browsing%20to%20either%20the%20Site%20Contents%20page%20or%20a%20document%20library.%20Apparently%20a%20fix%20for%20the%20issue%20will%20be%20rolling%20out%20soon.%26nbsp%3BA%20week%20or%20two%20ago%20there%20was%20an%20issue%20with%20the%20inability%20to%20change%20the%20hub%20site%20theme%20and%20the%20above%20was%20the%20suggested%20workaround.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-252524%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-252524%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20problem%20here.%26nbsp%3B%20Hopefully%20they%20sort%20this%20soon.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-252516%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-252516%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20having%20the%20exact%20same%20problem%20on%20a%20newly%20provisioned%20HUB%20site%2C%20provisioned%20around%2016%3A00%20GMT%2C%20and%20since%20removed%20HUB%20capability%20and%20re%20converted%20back%20to%20a%20HUB%20still%20unable%20to%20change%20the%20top%20nav.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1093040%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1093040%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F142545%22%20target%3D%22_blank%22%3E%40Daniel%20Schmidt%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20see%20that%20your%20original%20post%20was%20over%20a%20year%20ago%2C%20but%20I%20seem%20to%20have%20this%20problem%20also%20concerning%20the%20hub%20site%20nav%20bar.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESaving%20the%20URL%20for%20the%20link%20seems%20ok%20but%20saving%20the%20overall%20bar%20doesn't%20work.%20This%20results%20in%20no%20save.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20only%20thing%20that%20seems%20to%20work%20is%20to%20delete%20the%20link%20and%20start%20over%20with%20a%20new%20one.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2101915%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2101915%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F495200%22%20target%3D%22_blank%22%3E%40alandarr%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%2C%20I%20too%20am%20having%20trouble.%20The%20menu%20looks%20correct%20when%20viewed%20from%20a%20classic%20page%2C%20but%20the%20modern%20menu%20is%20still%20showing%20an%20old%20version.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2149515%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2149515%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20is%20mid-February%202021%20and%20I%20am%20seeing%20the%20same%20issue%20now.%20Any%20ideas%20Microsoft%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2155129%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2155129%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F118921%22%20target%3D%22_blank%22%3E%40Jessica%20Brennan%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20issue%20was%20caused%20by%20adding%20audiences%20to%20the%20menu%20items.%3C%2FP%3E%3CP%3EI%20found%20that%20adding%20a%20SharePoint%20group%20as%20an%20audience%20caused%20the%20problem.%3C%2FP%3E%3CP%3EUsing%20an%20AD%20groups%20works%20fine.%20Not%20ideal%2C%20but%20it%20works.%3C%2FP%3E%3CP%3ESometimes%20it%20is%20necessary%20to%20update%20the%20menu%20by%20changing%20its%20style%20on%20the%20hub%20site%20to%20force%20an%20update.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPaul%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2155672%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20update%20Hub%20Site%20Navigation%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2155672%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F269813%22%20target%3D%22_blank%22%3E%40paulmesser%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20still%20scratching%20my%20head%20on%20this%20one.%20I%20manage%20our%20SPO%2C%20but%20don't%20have%20access%20to%20AD%20to%20setup%20groups.%20Hopefully%20this%20will%20not%20be%20the%20case%20in%20the%20future.%20It%20makes%20audience%20targeting%20only%20half%20way%20useful!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Anyone else having issues today updating Hub Site navigation?  Tried Different Browsers, Users, Computer, existing and New Hub site... I make the change, hit Save and nothing changes.  I opened a ticket, trying to figure out if anyone else is having the same problem

16 Replies

Yes having the exact same problem on a newly provisioned HUB site, provisioned around 16:00 GMT, and since removed HUB capability and re converted back to a HUB still unable to change the top nav.

Same problem here.  Hopefully they sort this soon.

best response confirmed by Daniel Schmidt (Contributor)
Solution

You can edit the hub site navigation by browsing to either the Site Contents page or a document library. Apparently a fix for the issue will be rolling out soon. A week or two ago there was an issue with the inability to change the hub site theme and the above was the suggested workaround.

Thank you,

 

Workaround worked and MS has fixed it now

I am still experiencing this issue - I do not believe it has been fixed @Daniel Schmidt. I have a hub site with navigation defined and am trying to edit the URLs within each menu item - some update, others do not. @Daniel Schmidt re: work-around, I cannot edit the URLs from the Site Contents or a document library - I can add links, but not modify them. From the home page, sometimes the 'Save' button works, other times it appears to work but then does not close the menu - leaving only the option to 'Cancel'. I do not receive an error in either case. When the 'Save' button appears to work (saves and then closes navigation editing), not all updated links are actually saved. 

@Laurie Petrick - Mine was fixed a couple weeks ago, the workaround (Go Site Contents and then edit) also worked for me.     If you are still having problems then try a different browser, and if that does not work I would open a ticket with MS to see if your tenant got missed with the patch.

Thank you, will do.

@Laurie Petrick it looks as though I am also in the same boat and the previous workaround no longer works so I have resorted to using PowerShell to manage the navigation so if you can't wait for MS to fix the problem look at using the following PnP PowerShell cmdlets.


Get-PnPNavigationNode

Add-PnPNavigationNode
Remove-PnPNavigationNode

You will need to install the SharePoint Online PowerShell module in order to do this, there is the link https://github.com/SharePoint/PnP-PowerShell.

@Du Le- thank you!! I've also reached out to Microsoft to see if the afore-mentioned fix had been pushed out to early release customers only and if they can check our tenant to see if we'd received it. I really appreciate the PS script below - it's not my forte, so this is helpful.  Thanks again, Laurie


@Du Le wrote:

@Laurie Petrick it looks as though I am also in the same boat and the previous workaround no longer works so I have resorted to using PowerShell to manage the navigation so if you can't wait for MS to fix the problem look at using the following PnP PowerShell cmdlets.


Get-PnPNavigationNode

Add-PnPNavigationNode
Remove-PnPNavigationNode

You will need to install the SharePoint Online PowerShell module in order to do this, there is the link https://github.com/SharePoint/PnP-PowerShell.


 

@Daniel Schmidt 

I see that your original post was over a year ago, but I seem to have this problem also concerning the hub site nav bar.

 

Saving the URL for the link seems ok but saving the overall bar doesn't work. This results in no save.

 

The only thing that seems to work is to delete the link and start over with a new one.

@alandarr 

 

Yes, I too am having trouble. The menu looks correct when viewed from a classic page, but the modern menu is still showing an old version.

It is mid-February 2021 and I am seeing the same issue now. Any ideas Microsoft?

@Jessica Brennan 

 

My issue was caused by adding audiences to the menu items.

I found that adding a SharePoint group as an audience caused the problem.

Using an AD groups works fine. Not ideal, but it works.

Sometimes it is necessary to update the menu by changing its style on the hub site to force an update.

 

Paul

@paulmesser 

I'm still scratching my head on this one. I manage our SPO, but don't have access to AD to setup groups. Hopefully this will not be the case in the future. It makes audience targeting only half way useful!

Thanks Paul, 

I'm not using Audience targeting. I left the new items on the navigation list and over the weekend, they "magically" showed up. Today I made some more changes and will watch to see when they update. I moved the item that I added to the list and I changed the navigation header name. I don't have admin access so I usually wait and see if things work out overnight or a weekend, before going to IT. 

 

@paulmesser 

Try clearing your cache or checking the changes in an incognito browser.  I had a similar issue, but clearing the cache showed the changes.